PlAwAnSaI
Administrator
Operating a Network Using Multiple IP
Routing Protocols
Using Multiple IP Routing Protocols
Using Multiple Routing Protocols
[li]Interim during conversion[/li]
[li]Application-specific protocols
[/list]
[li]One size does not always fit all.[/li][/list]
[/li]
[li]Political boundaries
[li]Groups that do not work well with others[/li][/list]
[/li]
[li]Mismatch between devices
[li]Multivendor interoperability[/li]
[li]Host-based routers[/li][/list]
[/li]
Redistributing Route Information
Routes are learned from another routing protocol when a router redistributes the information between the protocols.
Using Seed Metrics
[li]Use the default-metric command to establish the seed metric for the route or specify the metric when redistributing.[/li]
[li]Once a compatible metric is established, the metric will increase in increments just like any other route.[/li][/list]
Redistribution with Seed Metric
Corrigendum: Table D change 30 to 130
Configuring and Verifying Route Redistribution
Redistribution Supports All Protocols
Code:
RtrA(config)#router rip
RtrA(config-router)#redistribute ?
bgp Border Gateway Protocol (BGP)
connected Connected
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
isis ISO IS-IS
iso-igrp IGRP for OSI networks
metric Metric for redistributed routes
mobile Mobile routes
odr On Demand stub Routes
ospf Open Shortest Path First (OSPF)
rip Routing Information Protocol (RIP)
route-map Route map reference
static Static routes
Configuring Redistribution into RIP
Code:
RtrA(config)#router rip
RtrA(config-router)#redistribute ospf ?
Process ID
RtrA(config-router)#redistribute ospf 1 ?
match Redistribution of OSPF routes
metric Metric for redistributed routes
route-map Route map reference
...
Default metric is infinity
Redistributing into RIP
Quote:
router rip
redistribute ospf 1 metric 3
Configuring Redistribution into OSPF
Code:
RtrA(config)#router ospf 1
RtrA(config-router)#redistribute eigrp ?
Autonomous system number
RtrA(config-router)#redistribute eigrp 100 ?
metric Metric for redistributed routes
metric-type OSPF/IS-IS exterior metric type for redistributed routes
route-map Route map reference
subnets Consider subnets for redistribution into OSPF
tag Set tag for routes redistributed into OSPF
...
[li][/list]
Default metric is 20.[/li]
[li]Default metric type is 2.[/li]
[li]Subnets do not redistribute by default.[/li]
Redistributing into OSPF
Quote:
router ospf 1
redistribute eigrp 100 subnets metric-type 1
Configuring Redistribution into EIGRP
Code:
RtrA(config)#router eigrp 100
RtrA(config-router)#redistribute ospf ?
Process ID
RtrA(config-router)#redistribute ospf 1 ?
match Redistribution of OSPF routes
metric Metric for redistributed routes
route-map Route map reference
...
[li][/list]
Default metric is infinity.[/li]
สำหรับการ Redistribute static route to EIGRP นั้นใส่ค่า Metric ก็ได้ ไม่ใส่ก็ได้ เหตุผลเพราะว่าถ้าไม่ใส่ค่า Metric ซึ่ง
Code:
http://forum.siamnetworker.com/board/index.php?topic=901
Redistributing into EIGRP
Quote:
router eigrp 100
redistribute ospf 1 metric 10000 100 255 1 1500
[li]Bandwidth in kilobytes = 10000[/li]
[li]Delay in tens of microseconds = 100[/li]
[li]Reliability = 255 (maximum)[/li]
[li]Load = 1 (minimum)[/li]
[li]MTU = 1500 bytes[/li][/list]
Configuring Redistribution into IS-IS
Code:
RtrA(config)#router isis
RtrA(config-router)#redistribute eigrp 100 ?
level-1 IS-IS level-1 routes only
level-1-2 IS-IS level-1 and level-2 routes
level-2 IS-IS level-2 routes only
metric Metric for redistributed routes
metric-type OSPF/IS-IS exterior metric type for redistributed routes
route-map Route map reference
..
Output Omitted
Routes are introduced as Level 2 with a metric of 0 by default.
Redistributing into IS-IS
Quote:
router isis
redistribute eigrp 100
Summarizing Routes
Route Summarization เป็นการทำงานที่ต่อเนื่องและมีพื้นฐานมาจากการ ออกแบบแอดเดรสด้วย VLSM และ CIDR เป็น feature หนึ่งที่ใช้ในอินเตอร์เน็ตสำหรับการยุบรวม เราติ้งเอนทรี จำนวนมากเข้าด้วยกัน เพื่อให้ประหยัดเนื้อที่ในหน่วยความจำ
วิธี และคอนฟิก Route Summarization นั้นจะแตกต่างกันไปในแต่ละ routing protocol เช่น
[li][/list]
EIGRP จะเซตอัพ route sum ในระดับ interface โดยตรง โดยใช้คำสั่ง ip summary-address eigrp ที่ interface ขาออก เช่น
int s0
ip summary-address eigrp 100 10.1.1.0 255.255.255.0
[/li]
[li]RIPv2 ก็กระทำที่ระดับ interface ขาออกไปยัง router เพื่อนบ้านเช่นกัน โดยใช้คำสั่ง ip summary-address rip เช่น
int s0
ip summary-address rip 10.1.1.0 255.255.255.0[/li]
[li]OSPF
[li]Consolidates[/list]
inter-area (IA) routes on an ABR ใช้คำสั่ง area range ใน router mode เช่น
router ospf 1
network 172.16.64.1 0.0.0.0 area 1
summary-address 172.16.32.0 255.255.224.0[/li]
[li]Consolidates external routes, usually on an ASBR
router ospf 100
network 172.16.64.1 0.0.0.0 area 1
summary-address 172.16.32.0 255.255.224.0[/li][/li]
[li]IS-IS
router isis
summary-address 140.100.104.0 255.255.252.0[/li]
[li]BGP เรียกว่า CIDR
router bgp 64100
aggregate-address 172.16.0. 0 255.248.0 .0
It's must be in routing table.[/li]
วิธีการคิดคำนวณว่าต้อง summary หรือ aggregate ออกมาแล้วได้ค่าอะไร ? เพื่อใส่ใน configure นั้น คิดแบบเดียวกัน
Controlling Routing Update Traffic
Using the passive-interface Command
Credit: Cisco
Routing Protocols
Using Multiple IP Routing Protocols
Using Multiple Routing Protocols
[li]Interim during conversion[/li]
[li]Application-specific protocols
[/list]
[li]One size does not always fit all.[/li][/list]
[/li]
[li]Political boundaries
[li]Groups that do not work well with others[/li][/list]
[/li]
[li]Mismatch between devices
[li]Multivendor interoperability[/li]
[li]Host-based routers[/li][/list]
[/li]
Redistributing Route Information
Routes are learned from another routing protocol when a router redistributes the information between the protocols.
Using Seed Metrics
[li]Use the default-metric command to establish the seed metric for the route or specify the metric when redistributing.[/li]
[li]Once a compatible metric is established, the metric will increase in increments just like any other route.[/li][/list]
Redistribution with Seed Metric
Corrigendum: Table D change 30 to 130
Configuring and Verifying Route Redistribution
Redistribution Supports All Protocols
Code:
RtrA(config)#router rip
RtrA(config-router)#redistribute ?
bgp Border Gateway Protocol (BGP)
connected Connected
eigrp Enhanced Interior Gateway Routing Protocol (EIGRP)
isis ISO IS-IS
iso-igrp IGRP for OSI networks
metric Metric for redistributed routes
mobile Mobile routes
odr On Demand stub Routes
ospf Open Shortest Path First (OSPF)
rip Routing Information Protocol (RIP)
route-map Route map reference
static Static routes
Configuring Redistribution into RIP
Code:
RtrA(config)#router rip
RtrA(config-router)#redistribute ospf ?
Process ID
RtrA(config-router)#redistribute ospf 1 ?
match Redistribution of OSPF routes
metric Metric for redistributed routes
route-map Route map reference
...
Default metric is infinity
Redistributing into RIP
Quote:
router rip
redistribute ospf 1 metric 3
Configuring Redistribution into OSPF
Code:
RtrA(config)#router ospf 1
RtrA(config-router)#redistribute eigrp ?
Autonomous system number
RtrA(config-router)#redistribute eigrp 100 ?
metric Metric for redistributed routes
metric-type OSPF/IS-IS exterior metric type for redistributed routes
route-map Route map reference
subnets Consider subnets for redistribution into OSPF
tag Set tag for routes redistributed into OSPF
...
[li][/list]
Default metric is 20.[/li]
[li]Default metric type is 2.[/li]
[li]Subnets do not redistribute by default.[/li]
Redistributing into OSPF
Quote:
router ospf 1
redistribute eigrp 100 subnets metric-type 1
Configuring Redistribution into EIGRP
Code:
RtrA(config)#router eigrp 100
RtrA(config-router)#redistribute ospf ?
Process ID
RtrA(config-router)#redistribute ospf 1 ?
match Redistribution of OSPF routes
metric Metric for redistributed routes
route-map Route map reference
...
[li][/list]
Default metric is infinity.[/li]
สำหรับการ Redistribute static route to EIGRP นั้นใส่ค่า Metric ก็ได้ ไม่ใส่ก็ได้ เหตุผลเพราะว่าถ้าไม่ใส่ค่า Metric ซึ่ง
Code:
http://forum.siamnetworker.com/board/index.php?topic=901
Redistributing into EIGRP
Quote:
router eigrp 100
redistribute ospf 1 metric 10000 100 255 1 1500
[li]Bandwidth in kilobytes = 10000[/li]
[li]Delay in tens of microseconds = 100[/li]
[li]Reliability = 255 (maximum)[/li]
[li]Load = 1 (minimum)[/li]
[li]MTU = 1500 bytes[/li][/list]
Configuring Redistribution into IS-IS
Code:
RtrA(config)#router isis
RtrA(config-router)#redistribute eigrp 100 ?
level-1 IS-IS level-1 routes only
level-1-2 IS-IS level-1 and level-2 routes
level-2 IS-IS level-2 routes only
metric Metric for redistributed routes
metric-type OSPF/IS-IS exterior metric type for redistributed routes
route-map Route map reference
..
Output Omitted
Routes are introduced as Level 2 with a metric of 0 by default.
Redistributing into IS-IS
Quote:
router isis
redistribute eigrp 100
Summarizing Routes
Route Summarization เป็นการทำงานที่ต่อเนื่องและมีพื้นฐานมาจากการ ออกแบบแอดเดรสด้วย VLSM และ CIDR เป็น feature หนึ่งที่ใช้ในอินเตอร์เน็ตสำหรับการยุบรวม เราติ้งเอนทรี จำนวนมากเข้าด้วยกัน เพื่อให้ประหยัดเนื้อที่ในหน่วยความจำ
วิธี และคอนฟิก Route Summarization นั้นจะแตกต่างกันไปในแต่ละ routing protocol เช่น
[li][/list]
EIGRP จะเซตอัพ route sum ในระดับ interface โดยตรง โดยใช้คำสั่ง ip summary-address eigrp ที่ interface ขาออก เช่น
int s0
ip summary-address eigrp 100 10.1.1.0 255.255.255.0
[/li]
[li]RIPv2 ก็กระทำที่ระดับ interface ขาออกไปยัง router เพื่อนบ้านเช่นกัน โดยใช้คำสั่ง ip summary-address rip เช่น
int s0
ip summary-address rip 10.1.1.0 255.255.255.0[/li]
[li]OSPF
[li]Consolidates[/list]
inter-area (IA) routes on an ABR ใช้คำสั่ง area range ใน router mode เช่น
router ospf 1
network 172.16.64.1 0.0.0.0 area 1
summary-address 172.16.32.0 255.255.224.0[/li]
[li]Consolidates external routes, usually on an ASBR
router ospf 100
network 172.16.64.1 0.0.0.0 area 1
summary-address 172.16.32.0 255.255.224.0[/li][/li]
[li]IS-IS
router isis
summary-address 140.100.104.0 255.255.252.0[/li]
[li]BGP เรียกว่า CIDR
router bgp 64100
aggregate-address 172.16.0. 0 255.248.0 .0
It's must be in routing table.[/li]
วิธีการคิดคำนวณว่าต้อง summary หรือ aggregate ออกมาแล้วได้ค่าอะไร ? เพื่อใส่ใน configure นั้น คิดแบบเดียวกัน
Controlling Routing Update Traffic
Using the passive-interface Command
Credit: Cisco