PlAwAnSaI
Administrator
เป็นการส่ง Packet จากต้นทางหนึ่งไปยังกลุ่มปลายทางพิเศษ โดยที่กลุ่มปลายทางพิเศษนั้นเป็นการแทนถึงกลุ่มของ Host ใดๆ ที่ต้องการ
PIM (Protocol Independent Modules):
เป็น Routing Protocol ที่ใช้ในการ Forward Multicast Traffic และทำการ Maintain Topology ของ Multicast Tree
IGMP Snooping หากว่า Traffic ที่เป็น Multicast นั้น จำเป็นที่จะต้องเดินทางผ่าน Switch Layer 2 ซึ่งไม่มีความสามารถในการพิจารณา Packet แล้วนั้น มันจำเป็นที่จะต้องใช้ IGMP Snooping และ CGMP (Cisco Proprietary) ในการที่จะ Relay ข้อมูลเกี่ยวกับ Frame และ MAC Address ให้กับ Switch Layer 2 เนื่องจากโดยธรรมชาติแล้ว Switch Layer 2 จะทำการ Flood Packet Multicast ออกไปยังทุกๆ Port ของ VLAN โดยอัตโนมัติ โดยที่ไม่มีการพิจารณา Packet ใดๆ ดังนั้น มันจึงต้องมี CGMP ที่จะทำการ Relay Packet ของ IGMP Snooping ไปยัง Switch Layer 2 ให้ทำการ ADD ข้อมูลลงไปใน CAM Table ของตนเพื่อรับรู้ว่า Packet นั้นๆ เป็นของ Multicast Network ใด
Cr: MUT
L2 Multicast:
- Xconnect by Interface Vlan or Sub Int with L2 ME-3400 Series Not Work
- VPLS with Interwork Not Work
- Pass PE is Work Only Xconnect on Physical Int and PC/Laptop Connected with PE if Used SW L2 ME-3400 Series Not Work
- SW L2 pure configured igmp snooping is work
[li]xconnect used sub int with L2 7600 series is work[/li]
Multicast “MPLS” VPNs/L3 Multicast
Code:
http://blog.ipexpert.com/2010/06/07/multicast-mpls-vpns
VLC Setup for Multicast Test
peakdrive.com/?p=440

Multicast Tutorial
Code:
http://www.garr.it/eventiGARR/emc_training/tutorials/mcast_tutorial.pdf
Code:
http://www.cisco.com/application/vnd.ms-powerpoint/en/us/guest/tech/tk363/c1506/ccmigration_09186a00801a2537.ppt
Test mVPN Configuration Template
Core Multicast
• SSM mode
• Default MDT : 239.11.1.1
VRF Multicast
• Static RP
• RP address 10.239.1.1
PE Configuration
Quote:
ip multicast-routing
ip multicast multipath
!
interface lo0
ip address 10.5.0.73 255.255.255.255
ip pim sparse-mode
!
!enable pim on all core facing interfaces
interface x/y
description Core-facing-Interface
ip pim sparse-mode
!
!enable SSM
ip pim ssm range 39
access-list 39 permit 239.0.0.0 0.255.255.255
!
!Configure multicast VRF ทำแค่บนตัวที่ต่อกับตัว Decoder
!Default MDT Configure
ip vrf IPTV-M
rd aaa:bbb
route-target export aaa:bbb
route-target import aaa:bbb
mdt default 239.11.1.1 -> สร้าง GRE Tunnel Multicast ต้องมี เป็น mandatory
!
ip multicast-routing vrf IPTV-M
!
interface x/y.z
description test IPTV
encapsulation dot1Q z
ip vrf forwarding IPTV-M
ip pim sparse-mode
ip address 10.239.7.1 255.255.255.252
!
router bgp aaa
address-family ipv4 mdt -> ไม่ใส่ pim neighbor ไม่ขึ้น
neighbor 10.5.0.252 activate
neighbor VPN-RR send-community both
!
ip pim vrf IPTV-M rp-address 10.239.1.1
P Configuration
Quote:
! Core-CRS
!
multicast-routing address-family ipv4
multipath
interface all enable
ssm range 39
!
ipv4 access-list 39
10 permit 239 .0.0.0 0.255.255.255
RR Configuration
Quote:
router bgp aaa
address-family ipv4 mdt
neighbor VPN-RR-CLIENT activate
neighbor VPN-RR-CLIENT send community both
neighbor VPN-RR-CLIENT route-reflector-client
neighbor 10.5.0.73 peer-group VPN-RR-CLIENT
Credit: P'Suwanna@Cisco
L2 Configuration
Quote:
ip igmp snooping
Verify MVPN on PE
[li]show ip pim vrf IPTV-M neighbor -> จะเห็นทุก PE ที่ configured multicast[/li]
[li]ip igmp join-group 239.255.1.1 -> บน vrf int ทดสอบเป็น Client โดย router[/li]
[li]ping ip vrf IPTV-M 239.255.1.1[/li]
[li][/li]
[li]show ip mroute[/li]
[li]show ip pim interface[/li]
[li]show ip pim neighbors[/li]
[li]show ip pim rp[/li]
[li]show ip rpf[/li][/list]
Testing Source Specific Multicast
Code:
http://blog.ipexpert.com/2011/02/09/testing-source-specific-multicast
Implementing Multicast Routing on Cisco IOS XR Software
Code:
http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.8/multicast/configuration/guide/mc38mcst.html
Default MDT and Data MDT Concept
Code:
https://learningnetwork.cisco.com/docs/DOC-3671
On ME-3600X must change sdm to application
#sdm prefer applications (on EXEC mode)
show ip mfib count : you can look at mfib count to check the number of packet received and forwarded and the number of drops to check if we can we are forwarding the number of packets received and they are not being dropped this would mean that the multicast stream is a healthy stream. If result is NA you can see by:
show ip mrib route 239.70.10.10 verbose
(192.168.10.84,239.70.10.10) RPF nbr: 10.5.0.60 Flags: K DDE
Tunnel1 Flags: A Next-hop: 239.232.0.2 // Flags are same for both mfib and mrib outputs is healthy multicast stream.
Vlan1914 Flags: F NS
show ip mfib 239.70.10.10 verbose
(192.168.10.84,239.70.10.10) Flags: K HW DDE
SW Forwarding: 0/0/0/0, Other: 0/0/0
HW Forwarding: 446523184/1891/1360/20107, Other: NA/NA/NA
Tunnel1, MDT/239.232.0.2 Flags: RA A MA
Vlan1914 Flags: RF F NS
ip igmp static-group configures a static connected member for a specific group. Traffic to that group will be fast-switched to the interface where this command is configured rather than process switched. This command is usually used to forward mcast traffic down an interface.
ip igmp join-group causes the router to send an IGMP membership report on the interface where it is configured. The mcast packets will therefore be received and process switched by the router hence more CPU intensive. This command is usually used for test purposes only.
high CPU 7600 because interface vrf multicast have rp-address is incorrect.
me360x-universalk9-mz.151-2.EY4.bin can't support multicast vpn. I used another version, The ip pim vrf neighbor is up but when I downgraded to this version not up.
Multicast Uses:
[*]Any applications with multiple receivers
- One-to-many
- Many-to-many
- Stock quotes, sports scores, magazines, newspapers, adverts
- VXLAN, etc. for BUM
- More than multiple point-to-point flows
- War games
- Virtual reality
broadbandnow.com/report/cable-vs-satellite-vs-iptv-vs-ott-streaming
