Basic MPLS VPN
  • การ Implement MPLS VPN เค้าทำกันยังไง มี Command พื้นฐาน, ขั้นตอนอะไรบ้าง?
    1. MPLS L2VPN:
      1. สร้าง IGP Route ให้เสร็จก่อน ในที่นี้จะใช้ IS-IS
      2. Run MPLS
      3. Destination Router:

        • Cisco no need configuration more

        • Nokia: SDP
          configure service sdp 123 mpls create
            far-end <destination router>
            ldp

        • Huawei:
          mpls ldp remote-peer <name>
           remote-ip <destination router>
           mpls ldp local-lsr-id LoopBack10 !If not need default loopback 0 interface

    2. MPLS L3VPN: Require เหมือนกับ L2VPN ข้อ 1 และ 2 แต่เพิ่มอีกข้อนึง
      3. Run MP-BGP แค่นี้แหละ เรามาทำพร้อมๆ กันเลยดีกว่า นี่ diagram ตามนี้

    image
    1. มาดูที่ P และ PE Router ว่าต้องทำอะไรบ้าง นี่เป็นของ Pauillac คับ
    • [li]router isis
      net 49.0001.0100.1001.0001.00 <- 0100.1001.0001 = 010.010.010.001 จริงๆ ใช้อะไรก็ได้ให้เป็น unique
      is-type level-1[/li]
      [li]interface Loopback0
      ip address 10.10.10.1 255.255.255.255
      ip router isis[/li]
      [li]interface GigabitEthernetx/x <- ทุก interface ที่จะให้ traffic ผ่าน
      description link to Pulligny
      ip address 10.1.1.1 255.255.255.252
      ip router isis
      isis network point-to-point[/li]

    2. P และ PE Router เช่นกัน
    • [li]ip cef <- บางรุ่นเป็น default อยู่แล้วไม่ต้องใส่[/li]
      [li]interface GigabitEthernetx/x <- ทุก interface ที่จะให้ traffic ผ่าน
      mpls ip
      mtu 1512[/li]

    3. อ่ะ เสร็จแล้วที่ P Router ทำแค่นั้นแหละ ต่อไป PE อย่างเดียว อันนี้ของ Pescara
    • [li]ip vrf Customer_A
      rd 100:110 <- เอาไว้ทำให้ vrf prefix ในแต่ละ site ไม่ซ้ำกัน
      route-target export 100:1000 <- เอาไว้ export (เอาออก vrf table VPN1) MP-BGP attribute ติดไปกับ VPN prefix (RD + IP address)
      route-target import 100:1000 <- เอาไว้ import (เอาเข้า vrf table VPN1) MP-BGP attribute ที่ติดมากับ VPN prefix (RD + IP address)[/li]
      [li]interface Loopback101
      ip vrf forwarding Customer_A <- สั่งให้ interface นี้ เป็น VRF-aware interface ของ vrf VPN1 (show ip vrf interface)
      ip address 200.0.4.1 255.255.255.0[/li]
      [li]router bgp 100
      bgp log-neighbor-changes <- สั่งให้ log สถานะ neighbor
      neighbor 10.10.10.6 remote-as 100
      neighbor 10.10.10.6 update-source Loopback0 <- ใช้ Loopback0 สำหรับ  verification and redundency issue
      address-family vpnv4
      neighbor 10.10.10.6 activate
      neighbor 10.10.10.6 send-community both
      exit-address-family
      address-family ipv4 vrf Customer_B
        redistribute connected
        no synchronization
      exit-address-family[/li]

    สงสัยบรรทัดไหนถามได้เลยคับ

    • Advanced MPLS breakout, PE CE link local protection, VPLS PE redundancy, L2VPN over IP core, MPLS-TE for L2 VFI balancing
      files.netcore.be/Cisco%20Networkers%202009%20-%20All%20Sessions/Breakouts/BRKIPM/BRKIPM-3071/BRKIPM-3071.pdf

      Default VPLS is Spanning Tree Shutdown

    • Verify Command & Troubleshooting MPLS VPN

    • gns3vault.com/mpls/basic-mpls-vpn

    • PE-to-CE Design Options:
      www.cisco.com/c/en/us/td/docs/solutions/Enterprise/Mobility/EPN/3_0/L3VPN_CVD/EPN-3-L3VPN/4_pecedesign.html

    • Huawei:
      labnario.files.wordpress.com/2013/05/mpls-l3vpn-on-huawei-routers.pdf
    B-)
  • 1 Comment sorted by
  • On 7600 PE:
    mls ipv6 vrf
    ipv6 unicast-routing
    !
    mpls label protocol ldp
    !
    router bgp 1
    address-family ipv6
     no synchronization
     neighbor 10.0.0.1 activate
     neighbor 10.0.0.1 send-community both
     neighbor 10.0.0.2 activate
     neighbor 10.0.0.2 send-community both
    exit-address-family
    !
    address-family vpnv6
     neighbor 10.0.0.1 activate
     neighbor 10.0.0.1 send-community both
     neighbor 10.0.0.2 activate
     neighbor 10.0.0.2 send-community both
    exit-address-family
    !        
    mpls ldp router-id Loopback0
    !
    vrf definition 6vpe
    rd 1:100
    route-target export 1:100
    route-target import 1:100
    !
    address-family ipv4
    exit-address-family
    !
    address-family ipv6
    exit-address-family
    !
    interface GigabitEthernetx/x
    description ce1
    vrf forwarding 6vpe
    ipv6 address x:410:210:1::1/64
    !
    router bgp 1
    !
    address-family ipv6 vrf 6vpe
     redistribute connected
     no synchronization
    exit-address-family

    Credit: P'Ohm@AIT

    On ASR / XR PE can enable 6VPE with no service impact following steps:

    1. If you peer BGP with 2 RRs, you can enable on one RR first.

    2. router bgp 1
       address-family vpnv6 unicast

    3. Create new Neighbor-group
      neighbor-group vpnv6-rr
        remote-as 1
        password encrypted 12413841
        update-source Loopback0
        address-family vpnv4 unicast
        !
        address-family vpnv6 unicast
        !
        address-family ipv4 mdt !if have MVPN

    4. Apply to RR neighbor
      neighbor 10.0.0.1
        use neighbor-group vpnv6-rr

    ASR / XR VRF configuration:

    vrf 6vpe
     address-family ipv6 unicast
      import route-target
       1:100
      !
      export route-target
       1:100
      !
    router bgp 1
     !
     vrf 6vpe
      rd 1:100
      address-family ipv6 unicast
       redistribute connected
      !
    interface TenGigE0/0/0/0.19
     vrf 6vpe
     ipv6 address 100:100:4::1/64
     encapsulation dot1q 19

    B-)