IOS XR (CRS-1, CRS-3, ASR9k)
  • CRS-1
    ซิสโก้สร้างสถิติโลกด้วยอินเทอร์เน็ตเราเตอร์ประสิทธิภาพสูงสุด ดาวน์โหลดเอกสารทั้งหมดจากหอสมุดรัฐสภาสหรัฐฯ ใช้เวลาเพียง 4.6 วินาที

    บริษัทซิสโก้ ซีสเต็มส์ อิงค์ เปิดเผยว่า Guinness World Records ได้ให้การรับรองว่า อุปกรณ์ Cisco Carrier Routing System (CRS-1) เป็นอินเทอร์เน็ตเราเตอร์ที่มีขีดความสามารถสูงสุด สามารถรับส่งข้อมูลด้วยอัตราความเร็ว 92 เทราบิต (92 ล้านล้านบิตต่อวินาที) และรองรับการทำงานได้มากกว่ารุ่นก่อนหน้านี้ถึง 100 เท่า ทั้งนี้ อุปกรณ์ CRS-1 ของซิสโก้นับเป็นเทคโนโลยีการเชื่อมต่อชนิดแรกที่ได้รับการบันทึกโดย Guinness World Records ซึ่งเป็นหน่วยงานที่ทำหน้าที่บันทึกการทำลายสถิติทั่วโลก

    อุปกรณ์ CRS-1 ของซิสโก้ ซึ่งได้รับการเปิดตัวเป็นครั้งแรกในเดือนพฤษภาคม 2547 เป็นอุปกรณ์เราติ้งประเภทใหม่ที่ออกแบบเป็นพิเศษสำหรับผู้ให้บริการโทรคมนาคมโดยเฉพาะ ด้วยความสามารถในการรองรับบริการข้อมูล เสียง และวิดีโอบนเครือข่ายอินเทอร์เน็ตโพรโตคอล (IP) อุปกรณ์ดังกล่าวเหมาะอย่างยิ่งสำหรับแอพพลิเคชั่นขนาดใหญ่ที่ต้องการแบนด์วิธสูง เช่น วิดีโอออนดีมานด์, เกมออนไลน์ และบริการโต้ตอบแบบเรียลไทม์ ทั้งนี้ เราเตอร์ IP ซึ่งซิสโก้เป็นผู้ริเริ่มผลิตในช่วงปี 2527 นับเป็นพื้นฐานของอินเทอร์เน็ตสาธารณะและเป็นหนึ่งในเทคโนโลยีที่มีความสำคัญมากที่สุดในช่วง 20 ปีที่ผ่านมา
    http://www.ryt9.com/s/prg/143576

    http://www.ciscoclub.in.th/index.php?topic=595

    • [li]process แยกออกจากกันโดยสิ้นเชิง แยกออกแต่ละ Module เพื่อลดโอกาส Downtime ตัวใดตัวหนึ่งตาย ตัวที่เหลือจะไม่มีปัญหาเหมือน IOS ธรรมดา[/li]
      [li]ที่เคยลอง มันจะมี interface MgmtEth ติดมาด้วย[/li]
      [li]CLI Prompt: CRS-1 จะเป็น RP/0/RP0/CPU0:router ซึ่งเวลา configure มันก็จะขึ้นแบบนี้แหละทุกบรรทัด
      [list][li]RP = Route processor card[/li]
      [li]0 = Single-rack chassis or 1st rack in multishelf chassis[/li]
      [li]RP# = Either RP0 or RP1[/li]
      [li]CPU0 = Always the same[/li]
      [li]router = router name/hostname[/li]
    [/li]
    [li]สามารถ configure ก่อน แล้ว plug card ทีหลังได้[/li]
    [li]ในการ commit แต่ละครั้ง มันก็จะเก็บ log ไว้ ว่าแต่ละครั้งได้ configure อะไรไปบ้าง ซึ่งเก็บได้ 100 commit สามารถ rollback ได้[/li]
    [li]ACL จะคล้ายๆ กับ name ACL ใน IOS และสามารถแทรกบรรทัดได้[/li]
    [li]ใช้ Routing Policy Language (RPL) แทน Route-map ซึ่งจะเหมือนกับเขียนโปรแกรม (if, then, else) สามารถลดจำนวนบรรทัดของ Route-map ลงได้ อย่างน้อยครึ่งนึง[/li]
    [li]int up ฝั่งเดียวได้นะคับ ต้อง sho cdp nei ดูลูกเดียว[/li]
    [li]L2-IP-L4-Payload
    IP MTU = IP-L4-Payload  = 1500
          = IP-TCP-Payload = 20+20+1460
    L2-MPLS-IP-L4-Payload
    MPLS MTU = MPLS-IP-L4-Payload  = 1500
            = MPLS-IP-TCP-Payload = 4+20+20+1456
    --- 10Gbps --- 1 Sec.
    (1500 byte x 8 )/10G = ?[/li]
    [li]สามารถกำหนดสิทธิ์ได้หลาย group ต่อหนึ่ง user เช่น configure security ได้ทุกอย่าง แต่อาจจะ ใช้ command routing ได้ไม่กี่ command เพื่อ verify[/li]
    [li]Multitopology IS-IS ใช้เมื่อมีทั้ง IPv4 และ 6 (Dual Stack) แยก topology ระหว่าง 4 กับ 6 ออกจากกัน[/li]
    [li]EBGP ต้องทำ RPL รับก่อน ไม่งั้น default มันเป็น deny[/li]
    [li]RPL ถ้าไม่ตรงเงื่อนไขเลย เจอ endif มันก็จะ drop คล้ายๆ acl น่าจะมีแค่ PBR ที่ไม่ drop แต่ไม่รู้จะเชื่อมกันได้มั้ย[/li]
    [li]QoS priority กับ bandwidth ใช้พร้อมกันไม่ได้ priority คือ maximum guarantee bandwidth ต้องใช้กับ police เสมอ, bandwidth คือ minimum guarantee[/li][/list]

    Configuration Command
    • [li]การ configure เวลาเราพิมพ์ command ไป มันจะไปเก็บไว้อีกที่นึง จะไม่เกิดผลกับตัวเราท์เตอร์ทันที (เหมือนกับ IOS) จนกว่าจะใช้ command commit แล้วจึงจะมีผล คล้ายๆ กับคำสั่ง cop run sta หรือ wri ใน IOS แต่ XR จะไม่มี sta มีแต่ run[/li]
      [li]ตัวอย่าง Configure Loopback:
      [list][li]RP/0/RP0/CPU0:router(config)#int lo0[/li]
      [li]RP/0/RP0/CPU0:router(config-if)#ipv4 add 12.9.42.110/16[/li]

    ที่ phy int ก็เหมือนกัน เปลี่ยนจาก ip เป็น ipv4 และ subnet เป็น / เลย (command ส่วนใหญ่จะต้องใส่ version ของ ip ด้วย)[/li]
    [li]RP/0/RP0/CPU0:router#configure exclusive คนที่ใส่ command นี้ จะ commit ได้คนเดียว คนอื่นไม่สามารถ commit ได้[/li]
    [li]RP/0/RP0/CPU0:router(config)#clear ใช้ลบ command ที่ configure ไว้ ที่ยังไม่ได้ commit[/li]
    [li]RP/0/RP0/CPU0:router(config)#commit replace เป็นการเอาของใหม่ทับของเก่า ก็คือ sho con เป็นยังไง เวลาผ่าน command นี้ sho run ก็จะเป็นแบบนั้นเลย หรือถ้าไม่ได้ configure อะไรไป มันก็จะกลายเป็นคล้ายๆ กับ write erase ใน IOS[/li]
    [li]ตัวอย่าง Configure OSPF:
    • [li]RP/0/RP0/CPU0:router(config)#router ospf 1[/li]
      [li]RP/0/RP0/CPU0:router(config-ospf)#router-id 172.20.10.10[/li]
      [li]RP/0/RP0/CPU0:router(config-ospf)#area 0[/li]
      [li]RP/0/RP0/CPU0:router(config-ospf-ar)#int g0/0/0/0[/li]
      [li]RP/0/RP0/CPU0:router(config-ospf-ar)#int g0/0/0/1[/li]
      [li]RP/0/RP0/CPU0:router(config-ospf-ar)#int lo0[/li]
    [/li]
    [li]ตัวอย่าง Configure IS-IS
    router isis lab
    is-type level-2-only -> IS-Type = Level 2 Only
    net 49.0007.0000.0000.0008.00
    address-family ipv4 unicast
      metric-style wide -> Metric Style = Wide
    !
    interface Loopback0
      passive
      address-family ipv4 unicast
      !
    !
    interface GigabitEthernet0/3/1/4
      hello-password hmac-md5 encrypted 02050D4808095E731F -> Hello Packet Authentication Mode Message Digest (when configure not encrypted command) if interop with IOS; IOS must used Key-Chain.
      address-family ipv4 unicast
      !
    !
    ![/li]
    [li]ตัวอย่าง Configure BGP
    route-policy Pass-All -> RPL Policy: Name = Pass-All
      pass -> Policy = pass all routes (default deny all)
    end-policy
    !
    router bgp 700
    address-family ipv4 unicast
      network 8.8.8.8/32 -> BGP Route: Loopback Interface
    !
    neighbor 7.7.7.7
      remote-as 700 -> IBGP
      password encrypted 030752180500701E1D -> Authentication Key
      update-source Loopback0
      address-family ipv4 unicast
      next-hop-self
      !
    !
    neighbor 192.168.2.2
      remote-as 200 -> EBGP
      password encrypted 121A0C0411045D5679
      address-family ipv4 unicast
      route-policy Pass-All in -> RPL Apply = IN
      route-policy Pass-All out -> OUT
      !
    !
    ![/li]
    [li]ตัวอย่าง Configure MPLS:
    • [li]RP/0/RP0/CPU0:router(config)#mpls ldp[/li]
      [li]RP/0/RP0/CPU0:router(config-ldp)#router-id 172.20.10.10[/li]
      [li]RP/0/RP0/CPU0:router(config-ldp)#int g0/0/0/0[/li]
      [li]RP/0/RP0/CPU0:router(config-ldp)#int g0/0/0/1[/li]
    [/li]
    [li]ตัวอย่าง Configure Local Switching เอาไว้ใช้ทดสอบ throughput ของ card
    interface TenGigE0/1/0/0
    l2transport = int te0/1/0/0 l2t -> มี dampening ก็ไม่ได้ เอาออกก่อนด้วย
    interface TenGigE0/1/3/0
    l2transport
    l2vpn
    xconnect group SIP-800
      p2p link1
      interface TenGigE0/1/0/0
      interface TenGigE0/1/3/0[/li]
    [li]vty-pool default 0 20 <-- คำสั่งเปิด line vty ให้มากกว่า 5 session ถ้าไม่ใส่ยังไงก็ไม่เพิ่ม[/li]
    [li]control-plane management-plane inband interface all allow telnet <-- เปิดให้ telnet inband ได้ (telnet เข้าตัวเองไม่ได้นะ)[/li]
    [li]telnet vrf default ipv4 server max-servers 20 เปิด telnet server ด้วยนะจ๊ะ[/li]
    [li]line vty exec-timeout
    (config)# line template test
    (config-line)# exec-timeout 100 0
    (config-line)# exit
    (config)# vty-pool default 0 4 line-template test[/li]
    [li]hw-module location 0/0/cpu0 reload ใช้เวลานานมาก 5 นาทีขึ้นไป ไม่ต้องตกใจ[/li]
    [li]L2VPN Over TE
    l2vpn
    logging pseudowire status
    pw-class non-1
      encapsulation mpls
      preferred-path interface tunnel 2041 fallback disable
      !
    !
    xconnect group non
      p2p link1
      interface TenGigE0/10/0/0
      neighbor 10.126.0.22 pw-id 2041
        pw-class non-1
      !
      !
    !
    !
    interface tunnel-te2041
    ipv4 unnumbered Loopback0
    destination 10.126.0.22
    record-route
    path-option 20 explicit name non-cmi
    logging events link-status
    ![/li]
    [li]SSH Step
    configure
    hostname router1
    domain name cisco.com
    exit
    crypto key generate rsa general-keys
    crypto key generate dsa
    configure
    ssh timeout 60
    ssh server enable[/li]
    [li]POS
    controller SONET0/8/0/0
    ais-shut
    path
      report pais
      report prdi
      ais-shut
    !
    report lais
    report lrdi
    clock source internal
    !
    controller dwdm0/8/0/0
    transmit-power -100
    wavelength 55
    rx-los-threshold -350
    admin-state in-service => มีแต่บน CRS-3 นะจ๊ะ ไม่ใส่ Tx ไม่มีนา
    !
    interface POS0/8/0/0
    description CRS-1 to CRS-3
    bandwidth 39813120
    cdp
    mtu 9004
    ipv4 address 10.127.0.129 255.255.255.252
    encapsulation ppp
    pos
      crc 32
    !
    load-interval 30
    dampening
    !

    (config)#controller soNET 0/8/0/0
    (config-sonet)#framing ?
      sdh    Select SDH framing
      sonet  Select SONET framing (default)[/li]
    [li](config)#no logging console -> no logging console[/li]
    [li]SDR(admin)#
    sdr SDR2
    location 0/6/*
    location 0/7/*
    !
    sdr SDR3
    location 0/10/*
    location 0/11/*
    !
    sdr SDR4
    location 0/14/*
    location 0/15/*
    !
    username cisco
    secret 5 $1$bBnm$IpRkQqxThHtewifz8vEFx0
    group root-system
    !
    aaa authentication login remote local -> enable admin plane authentication. This allows you to log in to the non-owner SDR and create local usernames and passwords.
    Configuring a Username and Password for a Non-Owner SDR
    Username:username@admin
    Password:xxxx

    username cisco
    secret 5 $1$GF7/$IK24YSio1qL9beJg31VBH0
    group root-lr[/li]
    [li]RP/0/RP0/CPU0:router(config)#aaa accounting commands -> Runs accounting for all commands at the specified privilege level.[/li][/list]

    Show Command
    • [li]show config เอาไว้ดูว่าตอนนี้เรา configure อะไรไปบ้าง ก่อนที่จะ commit คล้ายๆ sho run[/li]
      [li]show configuration commit list | i Oct  6 ดูว่ามี commit อะไรบ้าง มันจะเก็บไว้หมด
      9    1000000274  phu vty3        CLI        Thu Oct  6 12:09:39 2011
      10  1000000273  phu vty2        CLI        Thu Oct  6 12:08:08 2011[/li]
      [li]show configuration commit changes 1000000274 ดู command ที่ configure ไป
      Building configuration...
      interface TenGigE0/1/0/6
      no ipv4 address 10.127.0.34 255.255.255.252
      !
      end

      show configuration commit changes 1000000273
      Building configuration...
      interface TenGigE0/1/0/6
      no description MPLS 10GE
      !
      end[/li]
      [li]show configuration session ดูว่าใคร lock ไม่ให้ commit ไว้[/li]
      [li]sho hw- sub sta plu, sho controllers ten x/x/x/x phy | inc dBm = show ofc power[/li]
      [li]sho controllers tex/x/x/0 mac | inc PLA
      PLA 0 port 0  MAC enabled  Rx MAC enabled[/li]
      [li]sho controllers dwdm x/x/x/0 | inc Sta
      Controller State: up
      G709 Status
      Optics Status
              Status :          AQUIRING <- ถ้าขึ้นฝั่งไหนแสดงว่า RX ที่มาหามัน มีปัญหา ปกติจะต้องเป็น LOCKED และถ้าเกิด link flap มากเกินไปอาจจะทำให้ card hang ได้ ต้อง reload card[/li]
      [li]sho int a/b/c/d ดูชนิดหัว OFC (LX/SX/ZX), Traffic counters[/li]
      [li]sho int bri = sho int statu[/li]
      [li]sho l2v xco = sho mpl l2t vc[/li]
      [li]sho plat, sho hw- fpd loc all = show module[/li]
      [li](admin)# show env power-supply CRS-1 ใช้สาย 6 คู่ CRS-3 เสียบได้ 8 ลูก (สาย 8 คู่) ต่อ 1 source

      Thu Aug  5 00:18:29.492 DST
                      Power Supply        Voltage        Current
                      AC-REC AC-REC        (V)              (A)
      Zone 1:        [A], [B ]        54.965, 54.181  3.447,  4.073
      Zone 2:        [A], [B ]        54.671, 54.083  8.983,  8.670
      Zone 3:        [A], [B ]        55.063, 54.279  3.865,  4.073

      Total Current:  33.111 A
      Total Power  : 1804.049 W[/li]
      [li](admin)#sho inv | beg Cha ดู Serial ตัวอุปกรณ์
      NAME: "Chassis", DESCR: "Cisco CRS-1 Series 16 Slots Line Card Chassis"
      PID: CRS-16-LCC        , VID: V05, SN: UCB23311133[/li]
      [li](admin)#sho run ดู SDR Configuration[/li]


    MPLS Command Reference for the Cisco CRS Router, Release 4.0
    http://www.cisco.com/en/US/docs/routers/crs/software/crs_r4.0/mpls/command/reference/b_gr40crs1book.html


    MPLS Configuration Guide, Release 3.7
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.7/mpls/configuration/guide/gc37book.html


    ASR9000 BNG Training guide setting up PPPoE and IPoE sessions
    https://supportforums.cisco.com/docs/DOC-19702


    Secure Domain Router (SDR) Commands
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.6/system_management/configuration/guide/yc36sdr.pdf


    Routing System - Overview
    Next-generation core
    • [li]40-Gbps routing[/li]
      [li]Multishelf scale[/li]
      [li]Foundation for core consolidation[/li]

    IP POP Evolution - Scaling
    • [li]Historically, scaling a POP has always been a problem[/li]
      [li]Many interconnection technologies have evolved over time, but all need to occupy a "revenue generation slot"[/li]
      [li]POP consolidation leads to converged core, peering, and edge functions[/li]
      [li]High availability is one of the keys to POP consolidation[/li]

    Current POP Design - Interconnection
    Core Layer Insertion
    Core Layer Consolidation
    Routing System Configurations
    Single-shelf system
    4, 8 or 16 MSC and PLIM slots
    No fabric card chassis required:
    • [li]4 or 8 switch fabric cards in LCC[/li]

    Multishelf system (2.4 to 92.0 Tbps)
    • [li]2 to 72 16-slot LCCs only[/li]
      [li]1 to 8 FCCs[/li]

    Fabric card chassis
    Switch fabric
    • [li]Fiber cables interconnect LCC through FCC[/li]
      [li]Interchassis management system control plane traffic does not pass through fiber cables[/li]

    Basic Cisco CRS-1 Series Carrier Routing System Switch Fabric

    image

    Routing System Line Card Chassis
    Routing System Interfaces
    PLIMS
    • [li]16-port OC-48c/STM-16c POS/DPT[/li]
      [li]4-port OC-192c/STM-64c POS/DPT[/li]
      [li]1-port OC-768c/STM-256c POS[/li]
      [li]1-port OC-768/STM-256c DWMPOS with tunable DWDM optics[/li]
      [li]4-port 10-Gigabit Ethernet with tunable DWMPHY optics[/li]
      [li]8-port 10-Gigabit Ethernet[/li]

    SIPs and SPAs
    • [li]Shared port adapter (SPA) interface processor-800 (SIP-800)[/li]
      [li]2-port Clear Channel T3/E3[/li]
      [li]4-port Clear Channel T3/E3[/li]
      [li]4-port OC-3c/STM-1 POS[/li]
      [li]8-port OC12/STM4 POS[/li]
      [li]2-port OC48/STM16 POS/RPR[/li]
      [li]4-port OC48/STM16 POS/RPR[/li]
      [li]1-port OC-192c/STM-64 POS/RPR VSR[/li]
      [li]1-port OC-192c/STM-64 POS/RPR XFP[/li]
      [li]8-port Gigabit Ethernet[/li]
      [li]5-port Gigabit Ethernet-V2[/li]
      [li]8-port Gigabit Ethernet-V2[/li]
      [li]10-port Gigabit Ethernet-V2[/li]
      [li]1X10 Gigabit Ethernet-L-V2[/li]
      [li]1X10 Gigabit Ethernet-WL-V2[/li]

    Line Card Chassis - Overview
    Midplane design with front and rear access:
    • [li]Front
      [list][li]16 PLIM slots[/li]
      [li]2 RP slots and 2 fan controllers[/li]
    [/li]
    [li]Back
    • [li]16 MSC slots[/li]
      [li]8 fabric cards[/li]
    [/li][/list]
    Dimensions:
    • [li]23.6 in. W x 41.0 in. D x 84.0 in. H[/li]
      [li]60.0 cm W x 104.2 cm D x 213.4 cm H[/li]

    Power: ~13.2 kW (AC or DC)
    Weight: ~1600 lb (723 kg) fully loaded
              939 lb (426 kg) as shipped
    Heat diss.: 41,000 BTUs
    Chassis Components - PLIM Side
    Chassis Components - MSC Side
    Cable Management
    Cable management bracket has telescoping feature that allows bracket to be extended when chassis is upgraded with higher-density cards.
    Chassis Slot Numbers
    Chassis Power System - Overview
    Power system is fully redundant and comprises:
    • [li]AC or DC power shelves[/li]
      [li]3 AC rectifiers or 3 DC PEMs for each shelf[/li]
      [li]Alarm modules[/li]
      [li]Dual bus bars[/li]
      [li]Chassis midplane[/li]
      [li]Special components on cards or modules, like DC-to-DC converters, OR'ing diodes, or EMI filters[/li]

    Power Architecture
    Power system architecture provides fully redundant AC or DC power
    Chassis still operates normally when:
    • [li]One AC rectifier or DC PEM fails[/li]
      [li]One entire power shelf or bus bar fails[/li]

    Two failures have to happen in both A and B sides of power architecture that affect same load zone for system degradation to occur
    Same architecture is used for both AC and DC-powered chassis
    Three different types of power shelves: DC, AC Wye, and AC Delta
    Power Distribution

    Russian Doll - ตุ๊กตาแม่ลูกดก
    http://th.wikipedia.org/wiki/ตุ๊กตาแม่ลูกดก


    10-Gigabit Ethernet Transceiver Modules Compatibility Matrix ดูว่าการ์ด supported transceiver แบบไหนบ้าง
    http://www.cisco.com/en/US/docs/interfaces_modules/transceiver_modules/compatibility/matrix/OL_6974.html


    CRS-3
    Migrating to a Cisco CRS-3 Carrier Routing System, MSC-140G
    http://www.cisco.com/en/US/docs/routers/crs/software/crs_r4.0/migration/guide/ug40ug.html

    • [li]16 slot เสียบไป 3 card ไม่รวม rp, fc หม่ำไฟประมาณ source ละ 33 A[/li]


    Upgrade IOS Plan

    การ์ด 40 Gbps มี 2 แบบ
    • [li]B&W (Gray Lamda:Cisco CRS-1 Series 1xOC768/STM256 POS Interface Module/SR) fix ความถี่แสง มี Lamda เดียว[/li]
      [li]WDM (Color) เพราะมันมีหลาย Lamda[/li]


    Bringing Up the Cisco IOS XR Software on a Standalone Router
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.3/getting_started/installation/guide/gs33sngl.html


    ROM Monitor (ROMMON) Guide
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r2.0/getting_started/installation/guide/appx_ROM.html


    Configuring General Router Features
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.6/getting_started/configuration/guide/gs36cnov.html


    Configuring Additional Router Features
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.8/getting_started/configuration/guide/gs38init.html


    Implementing Secure Shell
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.3/security/configuration/guide/sc33ssh.html


    Configuring AAA Services
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r2.0/security/configuration/guide/scaaa.html


    Implementing NTP
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r2.0/system_management/configuration/guide/smcntp.html


    Terminal Services Commands
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.4/system_management/command/reference/yr34term.html


    Implementing EIGRP
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.4/routing/configuration/guide/rc34egp.html


    Static Routing Commands
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.7/routing/command/reference/rr37strt.html


    IS-IS Commands
    http://www.cisco.com/en/US/docs/routers/xr12000/software/xr12k_r4.2/routing/command/reference/b_routing_cr42xr12k_chapter_011.html


    Router Recovery with ROM Monitor
    http://www.cisco.com/en/US/docs/routers/xr12000/software/xr12k_r3.9/rommon/configuration/guide/rm39recv.html


    Configuring Ethernet Interfaces
    http://www.cisco.com/en/US/docs/routers/xr12000/software/xr12k_r4.2/interfaces/configuration/guide/hc42ethi.html


    Troubleshooting Interfaces
    http://www.cisco.com/en/US/docs/routers/crs/software/crs_r3.9/troubleshooting/guide/tr39int.html


    Command Prompts
    http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.2/general/command/reference/cm32prmt.html


    Cisco IOS XR – Complete Getting Started Examples Guide
    http://networkgeekstuff.com/networking/cisco-ios-xr-complete-getting-started-examples-guide


    Cisco ASR 9010 Router
    http://www.cisco.com/en/US/products/ps10076/index.html


    Cisco XR 12000 Series and Cisco 12000 Series Routers
    http://www.cisco.com/en/US/prod/collateral/routers/ps167/product_data_sheet0900aecd8027c8dd_ps6342_Products_Data_Sheet.html


    • [li]MSC-B มี licence 2 แบบ 20G กับ 40G #show hw-module linecard throughput[/li]
      [li]interface HundredGigE0/1/0/0
      l2transport
      !!% Subsystem(2599), Code(11): cerrno 0x45139600: Cannot configure an interface as L2 when L3 configuration exists
      commit replace[/li]

    Differentiation between FP-140G & MSC-140G
    [table][tr][td]FP-140G[/td][td]MSC-140G[/td][/tr]
    [tr][td]Optimized for peering edge and core applications[/td][td]Optimized for high-speed edge applications with enhanced QoS
    Massive interface and VLAN scalability
    Wire-rate hierarchical QoS[/td][/tr]
    [tr][td]Supports up to 8 queues per port[/td][td]Supports up to 64,000 queues and 12,000 interfaces in hardware[/td][/tr][/table]

    ไฟ status หน้า fabric card ไม่ติด
    • [li](admin)#sho led
          LOCATION        MESSAGE        MODE      STATUS
            0/SM0/*      IOS XR        DEFAULT  UNLOCKED[/li]
      [li](admin)#sho environment led
      0/SM0/*: Module (host) LED status says: OK[/li]
      [li](admin)#sho controllers fabric plane all
      Plane  Admin  Oper
      Id    State  State
      --------------------
      0      UP      UP    [/li]

    ผลได้ตามนี้แสดงว่า led เสียเฉยๆ ตัว card ยังใช้งานได้ปกติ
    [center]Cr: P'Teng@AIT[/center]
    Router Recovery with ROM Monitor: Reinstalling Cisco IOS XR Software on Cisco ASR 9000 Series Routers
    http://www.cisco.com/en/US/docs/routers/asr9000/software/asr9k_r4.0/rommon/configuration/guide/rm40recv.html


    % This command is not authorized
    RP/0/RP0/CPU0:R1(admin-config)#username cisco
    RP/0/RP0/CPU0:R1(admin-config-un)#group cisco-support
    RP/0/RP0/CPU0:R1#show ospf statistics interface summary
    % This command is not authorized
    RP/0/RP0/CPU0:R1#exi
    Username: cisco
    RP/0/RP0/CPU0:R1#show ospf statistics interface summary
    Mon Aug 26 19:06:12.583 UTC

    Services Interoperability between IOS and IOS-XR Example

    L2VPN P2P (Point to Point)
    [table][tr][td] IOS [/td][td]| IOS XR [/td][/tr]
    [tr][td] [/td][td]| [/td][/tr]
    [tr][td] interface TenGigabitEthernet2/1.210 [/td][td]| interface TenGigE0/0/0/1.205 l2transport [/td][/tr]
    [tr][td] description Test L2vpn1 ASR9K [/td][td]| encapsulation dot1q 205 [/td][/tr]
    [tr][td] encapsulation dot1Q 210 [/td][td]| rewrite ingress tag pop 1 symmetric [/td][/tr]
    [tr][td] xconnect 10.5.0.122 1173121103 encapsulation mpls [/td][td]| mtu 1544 [b]-> 1526+18
    [/td][/tr]
    [tr][td] [/td][td]| l2vpn [/td][/tr]
    [tr][td] #sho int te2/1.210 | inc MTU [/td][td]| pw-class mpls [/td][/tr]
    [tr][td]   MTU 1526 bytes, BW 10000000 Kbit, DLY 10 usec, [/td][td]|   encapsulation mpls [/td][/tr]
    [tr][td] [/td][td]|   control-word [/td][/tr]
    [tr][td] [/td][td]| xconnect group asrl2vpn [/td][/tr]
    [tr][td] [/td][td]|   p2p TestL2vpn1 [/td][/tr]
    [tr][td] [/td][td]|   interface TenGigE0/0/0/1.205 [/td][/tr]
    [tr][td] [/td][td]|   neighbor 10.5.0.73 pw-id 1173121103 [/td][/tr]
    [tr][td] [/td][td]|     pw-class mpls [/td][/tr][/table]
    show l2vpn xconnect interface te0/0/0/1.205 [detail]

    L3VPN
    PE-CE BGP routing

    [table][tr][td] IOS [/td][td]| IOS XR [/td][/tr]
    [tr][td] [/td][td]| [/td][/tr]
    [tr][td] ip vrf ABC [/td][td]| vrf ABC [/td][/tr]
    [tr][td]   rd 1:500 [/td][td]| address-family ipv4 unicast [/td][/tr]
    [tr][td]   route-target export 1:500 [/td][td]|   import route-target [/td][/tr]
    [tr][td]   route-target import 1:500 [/td][td]|   1:500 [/td][/tr]
    [tr][td] [/td][td]|   export route-target [/td][/tr]
    [tr][td] [/td][td]|   1:500 [/td][/tr]
    [tr][td] interface TenGigabitEthernet2/1.2303 [/td][td]| interface TenGigE0/0/0/2.2303 [/td][/tr]
    [tr][td]   description ABC [/td][td]| description ABC [/td][/tr]
    [tr][td]   encapsulation dot1Q 2303 [/td][td]| vrf ABC [/td][/tr]
    [tr][td]   ip vrf forwarding ABC [/td][td]| ipv4 address 172.28.208.9 255.255.255.252 [/td][/tr]
    [tr][td]   ip address 172.28.208.9 255.255.255.252 [/td][td]| encapsulation dot1q 2303 [/td][/tr]
    [tr][td] [/td][td]| [/td][/tr]
    [tr][td] router bgp 1 [/td][td]| router bgp 1 [/td][/tr]
    [tr][td]   address-family ipv4 vrf ABC [/td][td]| vrf ABC [/td][/tr]
    [tr][td]   no synchronization [/td][td]|   rd 1:500 [/td][/tr]
    [tr][td]   neighbor 172.28.208.10 remote-as 6 [/td][td]|   address-family ipv4 unicast [/td][/tr]
    [tr][td]   neighbor 172.28.208.10 activate [/td][td]|   neighbor 172.28.208.10 [/td][/tr]
    [tr][td] [/td][td]|   remote-as 6 [/td][/tr]
    [tr][td] [/td][td]|   address-family ipv4 unicast [/td][/tr]
    [tr][td] [/td][td]|     route-policy Pass-All in [/td][/tr]
    [tr][td] [/td][td]|     route-policy Pass-All out [/td][/tr][/table]
    show bgp vrf ABC summary

    PE-CE OSPF Routing
    [table][tr][td] IOS [/td][td]! IOS XR [/td][/tr]
    [tr][td] [/td][td]! [/td][/tr]
    [tr][td] interface TenGigabitEthernet2/2.3875 [/td][td]! interface TenGigE0/0/0/2.3875 [/td][/tr]
    [tr][td]   description BCD [/td][td]! description BCD043536 [/td][/tr]
    [tr][td]   encapsulation dot1Q 3875 [/td][td]! vrf BCD [/td][/tr]
    [tr][td]   ip vrf forwarding BCD [/td][td]! ip address 192.168.202.97 255.255.255.252 [/td][/tr]
    [tr][td]   ip address 192.168.202.97 255.255.255.252 [/td][td]! encapsulation dot1q 3875 [/td][/tr]
    [tr][td]   ip mtu 1500 [/td][td]! [/td][/tr]
    [tr][td]   ip ospf network non-broadcast [/td][td]! [/td][/tr]
    [tr][td]   ip ospf mtu-ignore [/td][td]! [/td][/tr]
    [tr][td]   no cdp enable [/td][td]! [/td][/tr]
    [tr][td] router ospf 200 vrf BCD [/td][td]! router ospf 200 [/td][/tr]
    [tr][td]   log-adjacency-changes [/td][td]! vrf BCD [/td][/tr]
    [tr][td]   redistribute connected subnets [/td][td]!   domain-id type 0005 value 000000C80200 -> C8 in Hex = 200 [/td][/tr]
    [tr][td]   redistribute static subnets [/td][td]!   redistribute bgp 1 [/td][/tr]
    [tr][td]   redistribute bgp 1 subnets [/td][td]!   address-family ipv4 unicast [/td][/tr]
    [tr][td]   network 192.168.202.96 0.0.0.3 area 1 [/td][td]!   area 1 [/td][/tr]
    [tr][td]   neighbor 192.168.202.98 [/td][td]!   interface TenGigE0/0/0/2.3875 [/td][/tr]
    [tr][td] [/td][td]!     network non-broadcast [/td][/tr]
    [tr][td] [/td][td]!     neighbor 192.168.202.98 [/td][/tr]
    [tr][td] [/td][td]!     mtu-ignore enable [/td][/tr]
    [tr][td] router bgp 1 [/td][td]! router bgp 1 [/td][/tr]
    [tr][td]   address-family ipv4 vrf BCD [/td][td]! vrf BCD [/td][/tr]
    [tr][td]   no synchronization [/td][td]!   rd 1:115015 [/td][/tr]
    [tr][td]   redistribute connected [/td][td]!   address-family ipv4 unicast [/td][/tr]
    [tr][td]   redistribute ospf 200 vrf BCD match internal external 1 external 2 [/td][td]!     redistribute connected [/td][/tr]
    [tr][td]   exit-address-family [/td][td]!     redistribute ospf 200 match internal external [/td][/tr][/table]
    ospf process id in each PE should use same value, the route between CE is 'O IA'.
    show ospf vrf BCD neighbor

    PE-CE Static Routing
    [table][tr][td] IOS [/td][td]! IOS XR [/td][/tr]
    [tr][td] [/td][td]! [/td][/tr]
    [tr][td] router bgp 1 [/td][td]! router bgp 1 [/td][/tr]
    [tr][td]   address-family ipv4 vrf CDE [/td][td]! vrf CDE [/td][/tr]
    [tr][td]   no synchronization [/td][td]!   rd 1:115044 [/td][/tr]
    [tr][td]   redistribute connected [/td][td]!   address-family ipv4 unicast [/td][/tr]
    [tr][td]   redistribute static [/td][td]!    redistribute connected [/td][/tr]
    [tr][td] [/td][td]!   redistribute static [/td][/tr]
    [tr][td] ip route vrf CDE 10.162.157.0 255.255.255.0 10.163.5.70 name CDE1 [/td][td]! router static [/td][/tr]
    [tr][td] ip route vrf CDE 10.162.254.157 255.255.255.255 10.163.5.70 name CDE1 [/td][td]! vrf CDE [/td][/tr]
    [tr][td] [/td][td]!   address-family ipv4 unicast [/td][/tr]
    [tr][td] [/td][td]!   10.162.157.0/24 10.163.5.70 description CDE1 [/td][/tr]
    [tr][td] [/td][td]!   10.162.254.157/32 10.163.5.70 description CDE1 [/td][/tr][/table] 8)
  • 3 Comments sorted by
  • XFP10GLR-192SR-L
    อธิบาย ตามโค้ด ทีละตัว
    xfp เป็น type interface มี xfp, xenpak
    10GLR คือ 10 Gigabit Ethernet , laser type LR ซึ่ง จะมี LR 10km, ER 40km, ZR 80km, SR 400m
    192SR หมายถึง OC192 short reach คือ สามารถเอาไปใส่ พวก SPA ที่เป็น POS ได้ ส่วนระยะทาง เท่ากัน แต่ framing เป็น Packet over Sonet จะมี 192SR, 192IR , 192LR
    ที่รหัส ห้อยท้าย จะมี -L / -RGD
    -L คือ low power consumtion กินไฟน้อย
    -RGD ไม่ประหยัดไฟ แต่ทนอุณหภูมิสูง
    Cr: P'Ohm@AIT
  • CRS Power Management

    Show power allotted each slot
    RP/0/RP1/CPU0:bk-labcrs8-2(admin)#show power allotted rack 0
    Tue Jul 22 19:58:45.564 BKK
    Node              Card Type         State             PID               Power Allotted  
    ----------------- ----------------- ----------------- ----------------- -----------------
    0/1/*             FP-140G           POWERED UP        CRS-FP140           450.0W
    0/1/PL0           1-100GbE-DWDM-    POWERED UP        1-100GE-DWDM/C      185.0W
    0/5/*             FP-140G           POWERED UP        CRS-FP140           450.0W
    0/5/PL0           1-100GbE          POWERED UP        1X100GBE            120.0W
    0/6/*             FP-140G           POWERED UP        CRS-FP140           450.0W
    0/6/PL0           14-10GbE          POWERED UP        14X10GBE-WL-XF      150.0W
    0/RP0/*           RP(H)-X86v1       POWERED UP        CRS-8-PRP-6G        175.0W
    0/RP1/*           RP(H)-X86v1       POWERED UP        CRS-8-PRP-6G        175.0W
    0/SM0/*           FC-140G/S(H)      POWERED UP        CRS-8-FC140/S       118.0W
    0/SM1/*           FC-140G/S(H)      POWERED UP        CRS-8-FC140/S       118.0W
    0/SM2/*           FC-140G/S(H)      POWERED UP        CRS-8-FC140/S       118.0W
    0/SM3/*           FC-140G/S(H)      POWERED UP        CRS-8-FC140/S       118.0W
    0/FAN-TR0         FAN TRAY          POWERED DOWN      CRS-16-LCC-FAN      151.0W
    0/FAN-TR1         FAN TRAY          POWERED DOWN      CRS-16-LCC-FAN      151.0W


    RP/0/RP1/CPU0:bk-labcrs8-2(admin)#show power capacity rack 0
    ---------------------------------------------------------
    Rack 0: Cisco CRS Modular DC Power System
    ---------------------------------------------------------

    Power Shelf A:
    ---------------------------------------------------------
    Power Module      State                Power Capacity  
    ----------------- ----------------- ---------------------
    A0                  OK                 2100.0W
    A1                  OK                 2100.0W
    A2                  OK                 2100.0W

    ---------------------------------------------------------
    Total Shelf Capacity:                  6300.0W               
    ---------------------------------------------------------


    Power Shelf B:
    ---------------------------------------------------------
    Power Module      State                Power Capacity  
    ----------------- ----------------- ---------------------
    B0                  OK                 2100.0W
    B1                  OK                 2100.0W
    B2                  OK                 2100.0W

    ---------------------------------------------------------
    Total Shelf Capacity:                  6300.0W               
    ---------------------------------------------------------


    ---------------------------------------------------------
    Total Rack Power Capacity:            12600.0W               
    ---------------------------------------------------------

    RP/0/RP1/CPU0:bk-labcrs8-2(admin)#show power summary rack 0
    Tue Jul 22 20:00:32.098 BKK
    Location   Power Capacity   Power Allotted   Power Available   Power State
    --------- ---------------- ----------------- ---------------- -------------
    Rack : 0         12600.0W          4799.0W           7801.0W            OK
    Cr: P'Ohm@AIT

    Cisco ASR 9000 Series Routers Environmental Specifications
    Operating Temperature
    http://www.cisco.com/c/en/us/td/docs/routers/asr9000/hardware/installation/guide/asr9kHIGbk/asr9kIGapaspecs.html#pgfId-1021557
  • Hardware Redundancy and Node Administration Commands on Cisco IOS XR Software
    hw-module subslot shutdown
    www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.7/system_management/command/reference/yr37hw.html#wp1211033

    Guidelines for Cisco IOS XR Software, SMR Version, EMR Version, Software Lifecycle
    www.cisco.com/c/en/us/products/collateral/ios-nx-os-software/ios-xr-software/product_bulletin_c25-478699.html