โจทย์การแข่งขัน National Networking Skill Competition 2009 คับ
  • คำแนะนำในการแข่งขัน
    • [li]กรุณากรอกชื่อผู้เข้าแข่งขันในหน้าตารางคะแนน พร้อมหมายเลข Pod number ที่ท่านได้[/li]
      [li]กำหนดให้ผู้เข้าแข่งขันใช้ PC ที่เตรียมไว้ให้ Install ระบบ Windows เป็นเครื่อง terminal ในการใช้ console และ telnet โดยให้ติดตั้งระบบ software ในการทำ Terminal และ TFTP Server ที่ได้แจกไว้ให้ใน CD Rom หรือจะใช้ tool ตัวอื่นๆ ที่มากับระบบ Windows ก็ได้[/li]
      [li]ผู้เข้าแข่งขันสามารถตัดสินใจเลือกทำข้อใดก่อนหลัง ก็ได้ ไม่จำเป็นต้องทำตามลำดับข้อ และหากไม่ประสงค์จะทำข้อใด ก็สามารถที่จะข้าม และเลือกทำข้อถัดไปได้ การให้คะแนนจะให้จากผลลัพธ์ที่ได้จากแต่ละข้อ[/li]
      [li]ผู้เข้าแข่งขันมีหน้าที่ที่จะต้องทำการบันทึกค่า save configuration หรือทำ backup configuration ไว้บนเครื่อง PC ในระหว่างการแข่งขัน อย่างสม่ำเสมอ เพื่อให้สามารถ recovery กลับมาได้ในกรณีที่มีความผิดพลาดเกิดขึ้น[/li]
      [li]ผู้เข้าแข่งขันสามารถทดสอบการจำลองการออกอินเตอร์เน็ตจาก PC ใน Pod ของตนโดยเรียกผ่าน web browser ไปที่ http://200.200.200.200 หรือทดสอบโดยการ Ping ไปที่ 200.200.200.1[/li]
      [li]เกณฑ์การตรวจ คณะกรรมการจะใช้วิธีในการ Telnet เข้าไปยังอุปกรณ์ router และ switch เพื่อ show running-configuration, show version ทดสอบโดยการ ping และ web browser เพื่อตรวจสอบความถูกต้อง คะแนนที่ได้จะได้เป็นข้อๆ ไป ผู้เข้าแข่งขันต้องทำให้ถูกต้องทั้งข้อจึงจะได้คะแนนตามที่ระบุไว้ หากถูกเพียงส่วนใดส่วนหนึ่งของข้อ ให้ถือว่าไม่ได้คะแนนในข้อนั้นๆ[/li]
      [li]ในกรณีที่มีผู้เข้าแข่งขันได้คะแนนเท่ากัน จะใช้ระยะเวลาในการทำที่สั้นที่สุดของผู้เข้าแข่งขันเป็นเกณฑ์การตัดสินสุดท้าย[/li]

    หมวดที่ 1: ทดสอบทักษะการทำ Admin บนอุปกรณ์ Router และ Switch
    • [li]บนอุปกรณ์ Router ที่เตรียมไว้ให้แต่ละกลุ่ม จะมีการ ใส่ enable password เอาไว้ ให้ผู้เข้าแข่งขันทำการ recovery password แล้วเปลี่ยนเป็น password ตามคำสั่งในข้อ 5 (ในกรณีที่ท่านทำข้อนี้ไม่ได้ ท่านสามารถไปขอให้กรรมการมาใส่ password ให้เพื่อทำข้อต่อไปได้ โดยท่านจะถูกตัดคะแนนในข้อนี้ไป (5 คะแนน)
      บูตเร้าเตอร์ใหม่ แล้วกด Ctrl+Break
      rommon 1 > confreg 0x2142
      rommon 2 > reset
      Router#copy startup-config running-config
      Router(config)#config-register 0x2102
      [/li]
      [li]จง Upgrade IOS image ของ Router ให้เป็น image ที่กำหนดให้ "c2800nm-advsecurityk9-mz.124-24.T.bin" (5 คะแนน)
      ติดตั้ง TFTP Server และสำเนาอิมเมจไฟล์ของ IOS ลงไปพร้อมทั้งสตาร์ท TFTP Server ขึ้นมา
      เชื่อมต่อเครื่องที่รัน TFTP Server กับเร้าเตอร์ โดยผ่าน LAN
      configure ให้เครื่องที่รัน TFTP Server กับพอร์ต LAN ของเร้าเตอร์สามารถ ping กันได้
      Router#copy tftp: flash:
      ถ้าพื้นที่ไม่พอ ต้องทำการลบข้อมูลในแฟลชออก ให้ backup ข้อมูลที่จะลบ ไว้ใน TFTP Server ก่อนสำเนาอิมเมจไฟล์ใหม่ไป
      [/li]
      [li]จงกำหนด Host name ของ Router ว่า "Router-X" และ Host name ของ Switch ว่า "Switch-X" (โดย X หมายถึงเลข Pod number ที่ท่านประจำอยู่) (1 คะแนน)
      Router(config)#hostname Router-11
      Switch(config)#hostname Switch-11
      [/li]
      [li]จงทำการตรวจสอบ configuration เพื่อให้แน่ใจว่า หากมีการ reload เกิดขึ้นบนอุปกรณ์ Router ของท่านภายหลังจากสิ้นสุดการแข่งขัน configuration ที่ได้ทำไว้บนอุปกรณ์ Router ของท่าน จะต้องไม่สูญหาย และ Router ยังคงสามารถทำงานได้ตาม startup-configuration เดิมที่ท่าน write mem ไว้ ก่อนที่จะมีการ reload (2 คะแนน)
      Router-11#show version
      Configuration register is 0x2102
      [/li]
      [li](ข้อ 5) จงเปลี่ยน Enable password บนอุปกรณ์ Router และ Switch ให้มี password เป็นคำว่า "cisco123" โดยหลังจากที่ใส่ password แล้ว เมื่อ show running-configuration ต้องเห็น password ในรูปแบบของ encrypted (1 คะแนน)
      (config)#enable secret cisco123[/li]
      [li](ข้อ 6)กำหนดให้สร้าง user บนอุปกรณ์ Router และ Switch โดยมี user name เป็น "admin" และ มี password เป็น "netacad" กำหนดให้ user admin มีระดับการเข้าถึงอุปกรณ์ privilege level 15 (1 คะแนน)
      (config)#username admin privilege 15 password netacad[/li]
      [li]อุปกรณ์ Router และ Switch ต้องสามารถ ทำการ Telnet เข้ามาจัดการอุปกรณ์ได้ โดยใช้ user name และ password ที่กำหนดให้ในข้อ 6 (1 คะแนน)
      Router-11(config)#line vty 0 4
      Router-11(config-line)#login local
      Switch-11(config)#line vty 0 15
      Switch-11(config-line)#login local
      [/li]
      [li]ให้สร้าง Access List ที่ Line VTY ของ Router เพื่ออนุญาติให้การ Telnet นั้นสามารถทำได้จาก Subnet ที่อยู่ใน VLAN 10 และ 20 ทั้งสองวง ของกลุ่มตัวเอง และ Subnet 172.16.100.0/24 ของ LAN ที่อยู่ใน HQ เท่านั้นที่สามารถ Telnet เข้ามาได้ Sub Network อื่นๆ นอกเหนือจากที่ระบุไว้ ไม่อนุญาติให้ Telnet เข้ามาที่ Router ได้ (3 คะแนน)
      Router-11(config)#access-list 1 permit 172.16.11.0 0.0.0.63
      Router-11(config)#access-list 1 permit 172.16.100.0 0.0.0.255
      Router-11(config)#line vty 0 4
      Router-11(config-line)#access-class 1 in
      [/li]
      [li]กำหนดให้ Router และ Switch สามารถ manage ด้วย SNMP protocol ได้ โดยมี public community string RO เป็น "public" และ private community string RW เป็น "cisco" (1 คะแนน)
      (config)#snmp-server community public ro
      (config)#snmp-server community cisco rw
      [/li]

    หมวดที่ 2: ทดสอบทักษะในการใช้งานระบบอินเตอร์เน็ตเราท์ติ้ง
    • [li]กำหนดให้ Router ที่แต่ละกลุ่มได้ เป็น Router ที่อยู่ในสำนักงานสาขา ให้ Config อุปกรณ์ Router เพื่อเชื่อมออกไปยังสำนักงานใหญ่ด้วย Sub-interface Fast Ethernet 0/0.1 ด้วย IP Address ตามที่กำหนดให้ คือ 192.168.xx.2/30 โดยกำหนดให้ใช้หมายเลข xx เป็นหมายเลขของ 802.1q บน sub-interface ด้วย (xx คือ หมายเลข 1-20 เรียงตาม Pod ของผู้เข้าแข่งขัน Pod1 = 1, Pod2 = 2 ..., Pod10 = 10, Pod11 = 11, Pod20 = 20) (1 คะแนน)
      Router-11(config)#interface fastEthernet 0/0.1
      Router-11(config-subif)#encapsulation dot1Q 11
      Router-11(config-subif)#ip address 192.168.11.2 255.255.255.252
      [/li]
      [li]ให้ Config อุปกรณ์ Router เพื่อเชื่อมออกไปยัง Internet ด้วย Sub-interface Fast Ethernet 0/0.100 ด้วย IP Address ตามที่กำหนดให้ คือ 64.104.66.xx/23 (xx คือ หมายเลข 1-20 เรียงตาม Pod ของผู้เข้าแข่งขัน Pod1 = 1, Pod2 = 2 ..., Pod10 = 10, Pod11 = 11, Pod20 = 20) โดยกำหนดให้ใช้หมายเลข 100 เป็นหมายเลขของ 802.1q บน sub-interface ด้วย (1 คะแนน)
      Router-11(config)#interface fastEthernet 0/0.100
      Router-11(config-subif)#encapsulation dot1Q 100
      Router-11(config-subif)#ip address 64.104.66.11 255.255.254.0
      [/li]
      [li]จงทำให้พอร์ต FastEthernet 0/0 สามารถใช้งานได้เป็นปกติ (Troubleshooting 1 คะแนน)
      Router-11(config)#interface fastEthernet 0/0
      Router-11(config-if)#no shutdown
      [/li]
      [li]Configure LAN Interface ของ Router สำนักงาน โดยกำหนดให้มีการเชื่อมต่อโดยอินเทอร์เฟส Fast Ethernet 0/1 ไปยัง Catalyst2960/2950 พอร์ต Fast Ethernet 0/24 โดยให้มีลักษณะการเชื่อมต่อแบบ VLAN Trunk 802.1q โดยพอร์ต Fast Ethernet 0/1 กำหนดให้ใช้ sub-interface Fast Ethernet 0/1.10 และ Fast Ethernet 0/1.20 เพื่อเชื่อมไปยัง VLAN 10 และ VLAN 20 ตามลำดับ (1 คะแนน)
      Router-11(config)#interface fastEthernet 0/1
      Router-11(config-if)#no shutdown
      [/li]
      [li]กำหนดให้ sub-interface Fast Ethernet 0/1.10 เชื่อมต่อไปยัง VLAN 10 ซึ่งเป็น subnet 172.16.x.0 มีขนาดของ subnet ที่รองรับจำนวน Host ได้ 30 Host Address และกำหนดให้ subnet นี้มี default gateway เป็น 172.16.x.1 (หมายเลข x คือหมายเลข Pod) (3 คะแนน)
      Router-11(config)#interface fastEthernet 0/1.10
      Router-11(config-subif)#encapsulation dot1Q 10
      Router-11(config-subif)#ip address 172.16.11.1 255.255.255.224
      [/li]
      [li]กำหนดให้ sub-interface Fast Ethernet 0/1.20 เชื่อมต่อไปยัง VLAN 20 โดยให้ใช้ network id ถัดไปจาก subnet 172.16.x.0 โดยมีขนาดของ subnet รองรับ 30 host address เช่นกัน และกำหนดให้ใช้ IP address แรกของ subnet นี้เป็น default gateway (3 คะแนน)
      Router-11(config)#interface fastEthernet 0/1.20
      Router-11(config-subif)#encapsulation dot1Q 20
      Router-11(config-subif)#ip address 172.16.11.33 255.255.255.224
      [/li]
      [li]กำหนดให้ add default route บน router สำหรับเชื่อมต่อไปยัง Internet โดยชี้ default route ไปที่ Interface Fast Ethernet 0/0.100 และมี next hop IP address เป็น 64.104.66.100 (1 คะแนน)
      Router-11(config)#ip route 0.0.0.0 0.0.0.0 fastEthernet 0/0 64.104.66.100[/li]
      [li]กำหนดให้สร้าง Dynamic Routing ด้วย Protocol OSPF โดยให้ประกาศเฉพาะ subnet ที่อยู่บน interface ดังต่อไปนี้เท่านั้น ไม่อนุญาติให้ประกาศ subnet อื่นๆ หรือ Network อื่นใด นอกเหนือไปจากนี้โดยเด็ดขาด (10 คะแนน)
      Router-11(config)#router ospf 1
      [list][li]Subnet ของ Interface Fast Ethernet 0/0.1
      Router-11(config-router)#network 192.168.11.0 0.0.0.3 area 0[/li]
      [li]Subnet ของ Interface Fast Ethernet 0/1.10 และ FE 0/1.20
      Router-11(config-router)#network 172.16.11.0 0.0.0.63 area 0[/li]
    [/li]
    [li]กำหนดให้ Host ใน VLAN 10 รับ DHCP มาจาก Router 172.16.100.1 ที่สำนักงานใหญ่ จง Config เพื่อให้ Subnet VLAN 10 สามารถรับ IP address จาก Router ที่สำนักงานใหญ่ได้อย่างถูกต้อง (5 คะแนน)[/li]
    [li]กำหนดให้ VLAN 20 เป็น subnet สำหรับ Guest โดยให้ท่านใช้ Router ในกลุ่มของท่านทำหน้าที่เป็น DHCP Server ในการจ่าย IP address พร้อมทั้ง Default Gateway ที่ถูกต้องให้กับเครื่องที่อยู่ใน VLAN 20 (5 คะแนน)[/li]
    [li]กำหนดให้ Subnet ใน VLAN 10 และ VLAN 20 สามารถออก Internet โดยการ NAT ออกไปยัง interface Fast Ethernet 0/0 ด้วย IP address ของ Fast Ethernet 0/0.100 (5 คะแนน)[/li]
    [li]เนื่องจาก VLAN 20 เป็น Guest VLAN จงสร้าง Access Control List สำหรับ Traffic ขาเข้าบน Interface Fast Ethernet 0/1.20 โดยอนุญาติเฉพาะเครื่อง PC ที่มี IP address อยู่ใน subnet ของ vlan20 เท่านั้น สามารถติดต่อกับ IP ใดๆ ใน Internet ได้ แต่ไม่อนุญาติให้เครื่อง PC ไม่ว่าจะเป็น IP Address ใดก็ตาม สามารถติดต่อกับ IP ของ subnet ใน VLAN 10 และ 172.16.100.0/24 และ 192.168.0.0/16 ได้ (5 คะแนน)[/li]
    [li]จงทำให้ผลของการใช้คำสั่ง show ip route แสดงค่าในบรรทัดของ 172.16.100.0/24 เป็น [110/2] เช่นเดียวกับตัวอย่างดังต่อไปนี้ (5 คะแนน)
    Router#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
          D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
          N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
          E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
          i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
          * - candidate default, U - per-user static route, o - ODR
          P - periodic downloaded static route

    Gateway of last resort is not set

        172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
    C       172.16.21.0/27 is directly connected, FastEthernet0/1.10
    C       172.16.21.32/27 is directly connected, FastEthernet0/1.20
    O       172.16.100.0/24 [110/2] via 192.168.1.1, 00:07:31, FastEthernet0/0.1[/li][/list]
    หมวดที่ 3: ทักษะในการออกแบบใช้งานระบบ LAN สวิตชิ่ง
    • [li]บน Switch ให้สร้าง VLAN 10 ให้มีชื่อว่า "Trust" และสร้าง VLAN 20 ให้มีชื่อว่า "Guest" (1 คะแนน)[/li]
      [li]กำหนดให้ Switch สามารถเข้ามาบริหารจัดการได้ โดยมี IP Address เป็น 172.16.x.2 และมี Default Gateway เป็น 172.16.x.1 (หมายเลข x คือหมายเลข Pod) (1 คะแนน)[/li]
      [li]กำหนดพอร์ต Fast Ethernet 0/24 บน Switch เป็นพอร์ตแบบ Trunk และอนุญาติให้เฉพาะ VLAN 10 และ 20 เท่านั้นที่สามารถส่งผ่านข้อมูลบนพอร์ตนี้ได้ (3 คะแนน)[/li]
      [li]กำหนดให้พอร์ต 1-6 สามารถเชื่อมต่อกับเครื่อง PC ได้ โดยให้อยู่ใน VLAN 10 และกำหนดให้พอร์ต 7-12 สามารถเชื่อมต่อกับเครื่อง PC ได้ โดยให้อยู่ใน VLAN 20 (1 คะแนน)[/li]
      [li]กำหนดให้พอร์ต 1-12 ซึ่งเป็น Access Port สำหรับต่อกับ End user PC สามารถ up ได้อย่างรวดเร็วโดยไม่ต้องรอ process การทำงานของ spanning tree ปกติ (3 คะแนน)[/li]
      [li]กำหนดให้ Switch ทำหน้าที่เป็น Root หลัก ของระบบ Spanning Tree ของ VLAN 10, 20 และห้ามไม่ให้ Switch อื่นที่อาจมาเชื่อมที่พอร์ต 1-12 ทำหน้าที่เป็น Root หลัก แทน (5 คะแนน)[/li]
      [li]กำหนดให้พอร์ตที่ 1-12 ต่อกับ PC ได้คราวละหนึ่งเครื่องเท่านั้น โดยให้กำหนดจำนวน MAC Address ที่ใช้งานได้ของพอร์ตเหล่านี้ ให้มีจำนวนสูงสุดไม่เกิน 1 MAC Address หากใช้งานเกิน ให้ switch ทำการ shutdown port นั้นทันที (3 คะแนน)[/li]
      [li]กำหนดให้พอร์ต 1-12 มีคุณสมบัติในการป้องกันการเชื่อมต่อกับอุปกรณ์ spanning tree อื่นๆ เช่น Hub หรือ Switch มาต่อพ่วงได้ (3 คะแนน)[/li]
      [li]กำหนดให้พอร์ตที่ 14 บน Switch ใช้เป็นพอร์ตที่จะเชื่อมต่อกับเครื่องวิเคราะห์เครือข่าย (เช่น Ethereal หรือ Sniffer) โดยให้ทำการ Mirror Traffic ใน VLAN 10 มายังพอร์ตที่ 14 นี้ (3 คะแนน)[/li]

    หมวดที่ 4: การทดสอบ End to End Connectivity (ต้องถูกต้องทั้งหมดจึงจะได้คะแนน)
    • [li]จง setup ให้เครื่อง PC ที่อยู่ใน VLAN 10 และ VLAN 20 ต้องสามารถรับ IP Address และ Default GW ที่ถูกต้องตามที่กำหนดไว้ได้ (2 คะแนน)[/li]
      [li]ทดสอบโดยการ เรียก web browser หรือ Ping จากเครื่อง PC ใน VLAN 10 และ VLAN 20 ไปยัง server http://200.200.200.200 จะต้องสามารถเข้าสู่หน้า web page ได้สำเร็จ (3 คะแนน)[/li]
      [li]ทดสอบการ Ping จากเครื่อง PC ใน VLAN 10 ไปยัง 172.16.100.1 ผลลัพธ์จะต้องสำเร็จ (3 คะแนน)[/li]
      [li]ทดสอบการ ping จากเครื่อง PC ใน VLAN 20 ไปยัง 172.16.100.1 และ 172.16.10.1 จะต้องไม่สำเร็จเพราะติด ACL (3 คะแนน)[/li]

    สรุป IP Address ที่กำหนดให้ใช้ในแต่ละกลุ่ม
    [table][tr][td]อุปกรณ์[/td][td]Interface[/td][td]IP Address[/td][td]หมายเหตุ[/td][/tr]
    [tr][td]Web server[/td][td][/td][td]200.200.200.1[/td][td][/td][/tr]
    [tr][td]ISP GW Router[/td][td][/td][td]64.104.66.100[/td][td][/td][/tr]
    [tr][td]Router[/td][td]Fast Ethernet 0/0.1[/td][td]192.168.x.2[/td][td]ตามลำดับของ Pod ที่ได้ Pod1 xx = 1, Pod20 xx = 20[/td][/tr]
    [tr][td][/td][td]Fast Ethernet 0/0.100[/td][td]64.104.66.xx/23[/td][td][/td][/tr]
    [tr][td][/td][td]Fast Ethernet 0.1.10[/td][td]172.16.xx.1[/td][td]x คือหมายเลข Pod ที่ได้ Pod1 x=1, Pod 20 x=20[/td][/tr]
    [tr][td][/td][td]Fast Ethernet 0/1.20[/td][td]172.16.xx.y[/td][td]x คือหมายเลข Pod ที่ได้ Pod1 x=1, Pod 20 x=20
    y คือหมายเลข IP address แรกของ subnet ที่สอง หลังจากที่มีการแบ่ง 172.16.x.0/24 ออกเป็น 8 subnet subnet ละ 30 host address[/td][/tr]
    [tr][td]Switch[/td][td]Interface vlan 10[/td][td]172.16.xx.2[/td][td]x คือหมายเลข Pod ที่ได้ Pod1 x=1, Pod 20 x=20[/td][/tr]
    [tr][td]PC1[/td][td]Fast Ethernet[/td][td]DHCP Vlan 10[/td][td]x คือหมายเลข Pod ที่ได้ Pod1 x=1, Pod 20 x=20[/td][/tr]
    [tr][td]PC2[/td][td]Fast Ethernet[/td][td]DHCP Vlan 20[/td][td]x คือหมายเลข Pod ที่ได้ Pod1 x=1, Pod 20 x=20[/td][/tr][/table]
    http://www.tempf.com/getfile.php?id=392638&key=4b7e7bbe2237b
    8)
  • 3 Comments sorted by
  • สู้ๆเฮีย เพื่อนๆเปนกำลังใจให้
  • เรียบร้อยแล้วทั่น ได้ที่ 6 อ่ะ ยังอ่อน :(
  • ขอแชร์หน่อยนะคับ ^^