SPADVROUTE question of the day
  • You noticed a recent change to the BGP configuration on a PE router, the bgp scan time has been changed from the default value to 30s. Which three effects will this change have?

    A. The BGP table will be examined and verified more frequently.

    B. The minimum time interval between sending EBGP and IBGP routing updates will decrease.

    C. The BGP convergence time will increase.

    D. The BGP keepalive messages will be sent to the BGP peers at a faster rate.

    E. The BGP table will be modified more quickly in the event that a next-hop address becomes unreachable.

    F. The CPU load of the router will increase.
  • 23 Comments sorted by
  • On Cisco IOS-XR, which BGP process can be distributed into multiple instances?

    A. BGP process manager

    B. BGP RIB process

    C. BGP scanner process

    D. BGP dampening process

    E. BGP speaker process
  • Refer to the configuration exhibit, taken from a Cisco IOS-XR router. Which configuration change is required to properly enable this router as the signaling router for implementing source-based RTBH filtering?

    router static
     address-family ipv4 unicast
      192.0.2.1/32 Null0
    !
    route-policy RTBH
     if tag is 666 then
      set next-hop 192.0.2.1
     endif
    end-policy
    !
    router bgp 65123
     address-family ipv4 unicast
      redistribute static route-policy RTBH
    !
    !When attacks are detected from 209.165.201.144/28
    !
    router static
     address-family ipv4 unicast
      209.165.201.144/28 null0 tag 666
    !

    A. pass in the route policy

    B. The 192.0.2.1/32 static route should be tagged as 666 (tag 666)

    C. set local-preference 1000 in the route policy

    D. set community (no-export) in the route policy
  • Refer to the Cisco IOS-XR BGP configuration exhibit. Identify two configuration errors.

    route-policy passall
      permit
    end-policy
    !
    router bgp 65123
     af-group abc address-family ipv4 unicast
      route-policy passall in
      route-policy passall out
     !
     neighbor-group efg
      password C!sc0!3o
      ttl-security
      update-source Loopback0
      maximum-prefix 10
      address-family ipv4 unicast
       use af-group abc
     !
     neighbor 209.165.201.130
      remote-as 65234
      use neighbor-group efg

    A. The neighbor-group efg is missing the ebgp-multihop 2 configuration.

    B. The route-policy passall in and route-policy passall out command should be configured under the neighbor-group efg instead of the af-group abc.

    C. The ttl-security configuration command is missing the option to set the number of hops.

    D. The maximum-prefix 10 configuration should be configured under the af-group abc instead of the neighbor-group efg.

    E. The passall route policy is wrong.
  • Which two statements correctly describe the RPF check when a multicast packet arrives at a router?

    A. If the packet has arrived on the interface leading back to the destination, the RPF check passes and the packet is forwarded. If the RPF check fails, the packet is dropped.

    B. The router looks up the destination address in the unicast routing table to determine if the packet has arrived on the interface that is on the reverse path back to the destination.

    C. The router looks up the source address in the unicast routing table to determine if the packet has arrived on the interface that is on the reverse path back to the source.

    D. If the packet has arrived on the interface leading back to the source, the RPF check passes and the packet is forwarded. If the RPF check fails, the packet is dropped.
  • Refer to the Cisco IOS-XR show output exhibit. Which statement is correct?

    RP/0/RSP0/CPU0:P1# show bgp neighbor 10.1.1.1 configuration
    Wed Oct 26 17:45:09.690 UTC
    neighbor 10.1.1.1
     remote-as 64500  [ ]
     update-source Loopback0  [ ]
     address-family IPv4 Unicast [ ]

    A. The [ ] indicates the configuration has a problem.

    B. The [ ] indicates the corresponding BGP peer configuration has a mismatch configuration.

    C. The [ ] indicates the configuration was not inherited from a group.

    D. The [ ] indicates the configuration has not been committed.

    E. The [ ] indicates the 10.1.1.1 neighbor peering session has not been established.
  • When enabling interdomain multicast routing, which two statements are correct?

    A. Multiprotocol BGP is used instead of PIM SM to build the intradomain and interdomain multicast distribution trees.

    B. MSDP SA packets are sent between the multiprotocol BGP peers.

    C. Noncongruent unicast and multicast topologies can be supported using multiprotocol BGP.

    D. Use MSDP to enable the RPs from different domains to exchange information about active multicast sources.
  • The 224.192.16.1 multicast IP address maps to which multicast MAC address?

    A. 01-00-5E-C0-16-01

    B. 01-00-5E-40-10-01

    C. 01-00-5E-C0-10-01

    D. 01-00-5E-00-10-01
  • The following Cisco IOS-XR configuration command will globally enable which multicast process(es) on the router?

    RP/0/RP0/CPU0:router(config)# multicast-routing

    A. PIM and IGMP and MLD

    B. PIM only

    C. PIM and IGMP only

    D. IGMP only

    E. IGMP and MLD only
  • When implementing interdomain multicast routing, which mechanism can be used to advertise multicast sources in one domain to the other domains, allowing the RPs to build interdomain multicast distribution trees?

    A. BSR

    B. MSDP

    C. MLD

    D. PIM

    E. Auto RP

    F. Multiprotocol BGP
  • Which two statements regarding Auto RP operations and implementations are correct?

    A. A Reverse Path Forwarding check is done on the RP discovery messages

    B. Candidate RPs send RP announcements to the 224.0.1.39 multicast group, and the mapping agents send RP discovery messages to the 224.0.1.40 multicast group

    C. Every PIM-SM router must be configured with the RP mapping agent IP address

    D. Administrative scoping can be configured to limit the scope of the RP announcements

    E. Candidate RPs learn the IP address of the mapping agents via periodic RP discovery messages

    F. RP discovery messages are flooded hop by hop throughout the network as multicast to the all PIM routers multicast group with a TTL of 1
  • What is determined by running the same hash algorithm on all PIMv2 routers?

    A. The SPT from the RP to the multicast source

    B. Which RP to use from a set of candidate RPs in the RP set

    C. The SPT from the last hop router to the multicast source

    D. Which BSR to use for a particular multicast group

    E. Auto RP election
  • When configuring PIM operations, what is the effect of setting the SPT threshold to infinity?

    A. The multicast source to the RP path will never switch over to the shortest path tree

    B. The receivers will be able to immediately switch over to the shortest path tree after receiving the first multicast packets on the shared tree via the RP

    C. All the PIM routers  will have more (S, G) states, thus consuming more router resources

    D. The last-hop routers will never switch over to the shortest path tree and will always remain on the shared tree
  • Which multicast group range is reserved for SSM?

    A. 225.0.0.0/8

    B. 232.0.0.0/8

    C. 239.0.0.0/8

    D. 224.0.0.0/8
  • Which four statement are correct regarding MSDP configurations and operations?

    A. The MSDP peers are also typically the RPs in respective routing domains

    B. SA messages are flooded to all other MSDP peers without any restrictions

    C. MSDP establishes neighbor relationships with other MSDP peers using TCP port 639

    D. MSDP peerings on Cisco IOS, IOS-XE, and IOS-XR support MD5 or SHA1 authentication

    E. On Cisco IOS, IOS-XE, and IOS-XR, the router can be configured to cache the SA messages to reduce the join latency

    F. SA messages are used to advertise active sources in a domain
  • When verifying multicast configurations and operations on Cisco IOS-XR routers, which two statements regarding show commands are correct?

    A. Use the show route ipv4 multicast command to display the incoming and outgoing interface lists for each of the joined multicast groups.

    B. Use the show pim rpf command to display the RPF information for the RP or for the multicast source.

    C. Use the show mrib route command to display the (*,G) and (S,G) states information on the router.

    D. Use the show mrib route command to display the configured static multicast routes.
  • Assume that the R1 router is enabled for PIM-SM and receives a multicast packet sourced from 172.16.1.100, and the R1 router has multicast receivers on the Gi0/1, Gi0/2, Gi0/3 and Gi0/4 interfaces. The multicast packet from the 172.16.1.100 source must arrive on which interface on the R1 router for it to be forwarded out the other interfaces?

    R1 routing table:

    172.16.1.0/24 via Gi0/1
    172.16.2.0/24 via Gi0/2
    172.16.3.0/24 via Gi0/3
    0.0.0.0/0 via Gi0/4

    A. Gi0/4

    B. Gi0/3

    C. Gi0/2 or Gi0/3

    D. Gi0/1 or Gi0/2 or Gi0/3 or Gi0/4

    E. Gi0/1 or Gi0/4

    F. Gi0/2

    G. Gi0/1
  • Refer to the exhibit. Which statement correctly explains the bgp graceful-restart command?

    router bgp 65123
     bgp graceful-restart
     !
     neighbor-group X
      graceful-restart

    A. This command is used to enable NSR and is entered on the NSR-capable router, and also on any NSR-aware peer

    B. This command is only required on the NSF-capable routers to enable BGP graceful restart with the BGP peers

    C. This command is only required on the NSR-capable routers to enable BGP graceful restart with the BGP peers

    D. This command is used to enable NSF and is entered on the NSF-capable router, and also on any NSF-aware peer

    E. This command is only required on the NSF-aware routers to enable BGP graceful restart with the BGP peers

    The data-forwarding plane of a router can continue to process and forward packets even if the control plane - which is responsible for determining best paths - fails. Also reduces routing flaps, which stabilizes the network and reduces the consumption of control-plane resources.
  • Refer to the exhibit. Which configuration is missing to complete the configuration task of enabling BFD with the 192.168.1.1 EBGP peer?

    router bgp 64500
     bfd multiplier 2
     bfd minimum-interval 20
     address-family ipv4 unicast
      network 10.1.1.0/24
     !
     address-family ipv6 unicast
     !
     neighbor 192.168.1.1
      remote-as 65001
      address-family ipv4 unicast
     !
    end

    A. bfd fast-detect also needs to be enabled for the 192.168.1.1 neighbor address-family under neighbor 192.168.1.1 address-family ipv4 unicast RP/0/RSP0/CPU0:P1(config-bgp-nbr-af)#bfd fast-detect

    B. bfd fast-detect also needs to be enabled for the address-family under address-family ipv4 unicast RP/0/RSP0/CPU0:P1(config-bgp-af)#bfd fast-detect

    C. bfd fast-detect also needs to be enabled for the 192.168.1.1 neighbor under neighbor 192.168.1.1 RP/0/RSP0/CPU0:P1(config-bgp-nbr)#bfd fast-detect

    D. bfd fast-detect also needs to be enabled globally on the router RP/0/RSP0/CPU0:P1(config)#bfd fast-detect

    E. bfd fast-detect also needs to be enabled globally under router bgp 64500 RP/0/RSP0/CPU0:P1(config-bgp)#bfd fast-detect
  • Which two features are used to provide high availability multicast?

    A. BFD

    B. IGMP triggered report

    C. PIM triggered join

    D. NSF/SSO

    E. PIM NSR

    F. MSDP
  • On Cisco IOS-XR, which BGP configuration group allows you to define address-family independent commands and address-family dependent commands for each address family?

    A. peer-group

    B. neighbor-group

    C. af-group

    D. session-group
  • Refer to the Cisco IOS-XR configuration exhibit. The Cisco IOS-XR router is unable to establish any PIM neighbor relationships. What is wrong with the configuration?

    multicast-routing
    !
    interface Loopback0
     ipv4 address 10.3.1.1 255.255.255.255
    !
    interface GigabitEthernet0/0/0/0
     ipv4 address 192.168.103.30 255.255.255.0
     no shut
    !
    interface GigabitEthernet0/0/0/1
     ipv4 address 192.168.156.50 255.255.255.0
     no shut
    !
    router isis 1
     net 49.0005.0100.0300.1001.00
     address-family ipv4 unicast
     !
     interface Loopback0
      address-family ipv4 unicast
     !
     interface GigabitEthernet0/0/0/0
      address-family ipv4 unicast
     !
     interface GigabitEthernet0/0/0/1
      address-family ipv4 unicast
    !
    router pim
     address-family ipv4
     auto-rp mapping-agent Loopback0 scope 16
     auto-rp candidate-rp Loopback0 scope 16
     !
     interface Loopback0
      enable
     !
     interface GigabitEthernet0/0/0/0
      enable
     !
     interface GigabitEthernet0/0/0/1
      enable
    !

    A. The configuration is missing:
    interface gi0/0/0/0
     ip pim sparse-mode
    interface gi0/0/0/1
     ip pim sparse-mode
    interface loopback0
     ip pim sparse-mode

    B. The RP address has not been configured using the rp-address router PIM configuration command

    C. PIM defaults to dense mode operations only, so PIM sparse mode must be enabled using the pim sparse-mode router PIM configuration command

    D. The configuration is missing:
    multicast-routing
     address-family ipv4
      interface gi0/0/0/0
       enable
      interface gi0/0/0/1
       enable

    E. The auto-rp scoping configurations should be set to 1 not 16
  • Referring to the topology diagram show in the exhibit, which three statements are correct regarding the BGP routing updates?

    image

    A. The IBGP routing updates received by R3 from R2 will be propagated to the R6 router.

    B. The IBGP routing updates received by R1 from R4 will be propagated to the R5, R7, and R2 routers.

    C. The IBGP routing updates received by R2 from R1 will be propagated to the R3 router.

    D. The EBGP routing updates received by R1 from R5 will be propagated to the R2, R4, and R7 routers.

    E. The EBGP routing updates received by R3 from R6 will be propagated to the R2 and R4 routers.

    F. The EBGP routing updates received by R1 from R5 will be propagated to the R2 and R4 routers.
  • When a BGP route reflector receives an IBGP update from a non-client IBGP peer, the route reflector will then forward the IBGP updates to which other router(s)?

    A. To the EBGP peers and other clients and non-clients.

    B. To the other clients only.

    C. To the EBGP peers only.

    D. To the EBGP peers and other clients only.