CCNA Service Provider (SP)
  • 640-875 SPNGN1 Exam Topics

    Exam Description

    The 640-875 Building Cisco Service Provider Next-Generation Networks, Part 1 exam is associated with the CCNA SP certification.  This exam tests a candidates basic knowledge and skills necessary to support a service provider network. Candidates can prepare for this exam by taking the Building Cisco Service Provider Next-Generation Networks, Part 1 (SPNGN1) course.

    Exam Topics
    The following topics are general guidelines for the content likely to be included on the Building Cisco Service Provider Next-Generation Networks, Part 1 exam. However, other related topics may also appear on any specific delivery of the exam. In order to better reflect the contents of the exam and for clarity purposes, the guidelines below may change at any time without notice.

    IP Networks
    • [li]Describe the purpose and functions of various network devices (at the core, distribution, and access layers)[/li]
      [li]Identify the functional components required to meet a given network specification[/li]
      [li]Describe the OSI and TCP/IP models and their associated protocols to explain how data flows in a network[/li]
      [li]Describe common network applications and their impact on the network[/li]
      [li]Interpret network diagrams[/li]
      [li]Troubleshoot common network problems at layers 1, 2, 3, 4, and 7 using a layered model approach[/li]
      [li]Describe differences between LAN and WAN operation and features[/li]

    IPv4 and IPv6 Addressing
    • [li]Describe the structure of IPv4 and IPv6 addresses[/li]
      [li]Describe VLSM, CIDR and route summarization concepts[/li]
      [li]Describe the different types of IPv4 and IPv6 addresses[/li]
      [li]Design an IP subnetting plan based on given requirements[/li]

    Switched Network Technologies I
    • [li]Describe bridging concepts and Layer 2 Ethernet frames[/li]
      [li]Configure basic Spanning Tree operations on Cisco IOS Switches[/li]
      [li]Interpret the output of various basic show and debug commands to verify the operational status of a Cisco switched network[/li]
      [li]Configure basic switch security (i.e, port security, securing unused ports)[/li]
      [li]Describe Ethernet link bundling, LACP, and PAgP and Flex Links[/li]

    Routed Network Technologies I
    • [li]Describe classful versus classless routing[/li]
      [li]Describe routing protocols basics (metrics, IGP versus EGP)[/li]
      [li]Describe RIPv1, RIPv2, RIPNG[/li]
      [li]Implement EIGRPv4 and EIGRPv6 on Cisco IOS, IOS-XE and IOS-XR routers[/li]
      [li]Describe route redistribution[/li]
      [li]Describe VRF[/li]
      [li]Describe GRE[/li]

    IP Services
    • [li]Configure NAT (IPv4) on Cisco routers[/li]
      [li]Configure DHCP (IPv4 and IPv6) operations on Cisco routers[/li]
      [li]Describe ICMPv4 and ICMPv6[/li]
      [li]Describe DNS[/li]

    Cisco Operating Systems and Platforms I
    • [li]Implement basic Cisco IOS, IOS-XE and IOS-XR CLI operations[/li]
      [li]Implement basic Cisco IOS, IOS-XE and IOS-XR routers configurations[/li]

    Transport Technologies
    • [li]Describe SONET and SDH[/li]
      [li]Describe DWDM, IPoDWDM, and ROADM[/li]
      [li]Configure 10 Gigabit Ethernet, 40 Gigabit Ethernet, and 100 Gigabit Ethernet interfaces on Cisco routers[/li]
      [li]Describe Frame Relay[/li]
      [li]Describe ATM[/li]
      [li]Describe Metro Ethernet[/li]
      [li]Describe DSL[/li]
      [li]Describe T1, T3, E1, E3, and ISDN[/li]
      [li]Implement PPP encapsulation on Cisco routers serial and POS interfaces[/li]
      [li]Describe cable (DOCSIS)[/li]
      [li]Describe the main BRAS and BNG routers functions in IP NGN[/li]
      [li]Describe various Passive Optical Network (PON) access technologies and FTTx[/li]

    Security in the Network
    • [li]Describe Layer 2 security features on Cisco IOS switches[/li]
      [li]Configure management plane security on Cisco routers and IOS switches[/li]
      [li]Describe IPsec[/li]
      [li]Describe control plane security[/li]
      [li]Configure basic AAA (TACACS+ and RADIUS) services on Cisco routers[/li]
      [li]Configure routing protocols authentication between Cisco routers[/li]
      [li]Describe the relationships between users, user groups, tasks groups and task IDs in IOS-XR[/li]
      [li]Describe common types of network attacks[/li]

    Network Management
    • [li]Configure NTP server or client on Cisco routers[/li]
      [li]Configure IP SLA on Cisco routers[/li]
      [li]Configure CDP on Cisco routers and IOS switches[/li]
      [li]Configure SNMP on Cisco routers[/li]
      [li]Configure NetFlow on Cisco routers[/li]
      [li]Configure logging to Syslog server on Cisco routers[/li]
      [li]Describe the Cisco IOS Call-Home feature[/li]
      [li]Describe Cisco TAC procedure and navigate Cisco support tools (CCO)[/li]
      [li]Implement management access (SSH, telnet, and out-of-band management design)[/li]
      [li]Implement SPAN, RSPAN, and ERSPAN[/li]
      [li]Implement file transfers to manage network devices configurations and images using FTP, SCP, TFTP, SFTP, and RCP[/li]

    Set authentication, frame-relay, NAT, DHCP
    ข้อแตกต่างของ RIP, OSPF และ EIGRP
    PAP & CHAP
    เครือข่ายความเร็วสูง, SONET/SDH
    VRF คืออะไร เอาไว้ทำอะไร ?
    IOS XR
    Variable Length Subnet Mask (VLSM)
    Internet Protocol version 6 (IPv6)
    DWDM เทคโนโลยีสื่อสารความเร็วสูงสำหรับเส้นใยแก้ว
    SNMP & SNMP Trap
    Cisco IOS IP Service Level Agreement (SLA)
    ME3400
    เกี่ยวกับ IEEE 802
    NetFlow
    • [li]Routing protocol authentication
      [list][li]MD5 passwords are never sent to a peer.[/li]
      [li]Routers authenticate each routing update packet received.[/li]
      [li]MD5 authentication must be configured with the same password on both BGP peers.[/li]
    [/li]
    [li]Private IP Address (RFC 1918) คือ IP Address ที่สงวนไว้สำหรับใช้ภายในองค์กร โดยที่หมายเลข IP
    Address เหล่านี้ไม่สามารถนำไปใช้งานใน Internet ได้
    • [li]Class A = 10.0.0.0 - 10.255.255.255[/li]
      [li]Class B = 172.16.0.0 - 172.31.255.255[/li]
      [li]Class C = 192.168.0.0 - 192.168.255.255[/li]
    [/li][/list]

    ARP, RARP, Proxy ARP, Gratuitous ARP and IP Redirect คือ ?
    http://www.ciscoclub.in.th/index.php?topic=715

    http://en.wikipedia.org/wiki/EtherType


    เร้าติ้งโปรโตคอลแบ่งตาม Classless และ Classful
    http://www.gotoknow.org/blogs/posts/306789


    ทำความรู้จักกับ Port Security บน Cisco Catalyst Switch
    http://running-config.blogspot.com/2011/01/port-security-cisco-catalyst-switch.html

    http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/port_sec.html


    Reliable Delivery and Filtering for Syslog
    http://www.cisco.com/en/US/docs/ios/12_4t/12_4t11/htnmsylg.html


    Command Copy TFTP Running-config This command lets you merge your backed up config
    http://www.howtonetwork.net/public/659.cfm


    Spanning Tree Protocol (STP), สาเหตุที่ทำให้เกิด loop, การหา Root Bridge, Mode การทำงาน, Blocking,
    http://www.compspot.net/index.php?option=com_content&task=view&id=351

    http://www.orbit-computer-solutions.com/How-the-Root-Bridge-and-Ports-are-chosen.php


    Managing Configuration Files Configuration Guide, Cisco IOS XE Release 3S
    <br />http://www.cisco.com/en/US/docs/ios-xml/ios/config-mgmt/configuration/xe-3s/Managing_Configuration_Files_Configuration_Guide_Cisco_IOS_XE_Release_3S.html

    • [li]Given the IP address 172.16.170.15 255.255.224.0, the subnet = 172.16.160.0/19, the host IP address range = 172.16.160.1 to 172.16.191.254, and the subnet broadcast IP address = 172.16.191.255

      [/li]
      [li]image

      7 collision domains and 2 broadcast domains shown in the exhibit.

      [/li]
      [li]image

      5 collision domains and 2 broadcast domains shown in the exhibit.

      [/li]
      [li]10.159.255.254/13, 10.158.255.255/13 and 10.153.0.1/13 are valid for hosts that belong to the 10.152.0.0/13 subnet.

      [/li]
      [li]The ff00::/8 prefix denote multicast type of IPv6 address.

      [/li]
      [li]With IPv6, for router and prefix discovery purpose are router solicitation and router advertisement used.

      [/li]
      [li]The first 3 bits IPv6 global unicast addresses is 001.

      [/li]
      [li]Given the IP address 10.106.170.145 255.248.0.0, subnet = 10.104.0.0/13, host IP address range = 10.104.0.1 to 10.111.255.254, and the subnet broadcast IP address = 10.111.255.255

      [/li]
      [li]Robert is sending an instant message to Mary. The message will be broken into a series of packets that will traverse all network devices.

      image

      The source MAC = 0000.000c.0123, source IP = 10.1.2.2, destination MAC = 0000.000c.0124, and destination IP = 10.1.3.3 that will populate these packets as they are forwarded from Router2 to Router1.

      [/li]
      [li]Frame Relay is Layer 2 WAN protocol uses DLCI as the virtual circuit identifier.

      [/li]
      [li]Packet over SONET:
      The Cisco POS interface supports Cisco HDLC and PPP encapsulation.
      The Layer 2 frame is encapsulated into a generic HDLC header (not Cisco proprietary HDLC) and placed into the appropriate SONET Payload Envelope.

      [/li]
      [li]GRE + IPsec is mechanisms are often used together to allow dynamic routing over a secured site-to-site VPN tunnel

      [/li]
      [li]IPv4 DHCP operations:
      If the DHCP clients and servers are on the same subnet, DHCP uses UDP broadcasts to communicate between the clients and servers.
      If the client and server are on different subnets, DHCPDISCOVER and DHCPREQUEST messages are sent via UDP broadcasts, but DHCPOFFER and DHCPACK messages are unicast.

      [/li]
      [li]VRF is Cisco router feature allows multiple independent routing table instances to co-exist within the same router at the same time.

      [/li]
      [li]Refer to the exhibit.

      image

      Company 1 has merged with Company 2. Company 1 is using RIPv2 as its IGP and Company 2 is using EIGRP as its IGP. EIGRP also is running between R1 and R2 over the WAN link.
      The Company 1 RIP routes appear as external EIGRP routes within Company 2.
      The Company 2 EIGRP routes appear as RIPv2 routes within Company 1.
      Configure mutual route redistribution between RIPv2 and EIGRP on the R1 router is action must be taken.

      [/li]
      [li]Statements about these partial Cisco IOS/IOS-XE configurations:
      interface e0
      ip address 192.168.1.1 255.255.255.0
      ip nat outside
      !
      interface e1
      ip address 10.1.1.1 255.255.255.0
      ip nat inside
      !
      ip nat inside source static 10.1.1.2 192.168.1.2

      10.1.1.2 is the inside local address.
      This is an example of static one-to-one Network Address Translation.

      [/li]
      [li]
      interface Ethernet0
      ip address 192.168.3.1 255.255.255.0
      ip nat inside
      !
      interface Ethernet1
      ip address 192.168.4.1 255.255.255.0
      ip nat inside
      !
      interface Serial0
      ip address 172.17.38.1 255.255.255.0
      ip nat outside
      !
      ip nat inside source list 1 interface Serial0 overload
      !
      access-list 1 permit 192.168.3.0 0.0.0.255
      access-list 1 permit 192.168.4.0 0.0.0.255

      Configuration is necessary to support this output:
      RouterX# show ip nat translations

      Pro  Inside global        Inside local      Outside local    Outside global
      TCP  172.17.38.1:1050    192.168.3.7:1050  10.1.1.1:23      10.1.1.1:23
      TCP  172.17.38.1:1776    192.168.4.12:1776  10.2.2.2:25      10.2.2.2:25


      [/li]
      [li]Neighbor discovery protocol in ICMPv6 is IPv6 feature replaced and enhanced the IPv4 ARP functions.

      [/li]
      [li]DSL-based Internet services for residential users:
      At the DSL service provider location, a DSLAM is used to terminate and then aggregate the DSL connections over an ATM network.
      The most commonly installed DSL variant for residential deployments is ADSL.
      Most residential deployments use PPPoE encapsulation where the end user PC or the DSL CPE will require a PPP username and password configuration.

      [/li]
      [li]Given the Class C IP network of 192.168.1.0, using VLSM, subnets meet the requirements in the exhibit:

      image

      192.168.1.0/27
      192.168.1.32/27
      192.168.1.64/28
      192.168.1.80/28
      192.168.1.96/30

      [/li]
      [li]Refer to the exhibit:

      image

      Transport and application layers of the TCP/IP model operates end-to-end (Host A to Host B).

      [/li]
      [li]Applications require the network to have the least amount of jitter, delay, and packet loss:
      VoIP
      Cisco TelePresence

      [/li]
      [li]per-vlan rapid spanning tree (rapid-pvst) is the default spanning-tree mode of an NNI port on a Cisco ME3400 switch.

      [/li]
      [li]Transparent bridging operations:
      A bridge operates at the data link layer.
      A bridge sends unknown unicast frames out on all ports except the incoming port.

      [/li]
      [li]According to this show output:
      SW1#show port-security interface fa0/1

      Port Security              : Enabled
      Port Status                : Secure-up
      Violation Mode            : Shutdown
      Aging Time                : 0 mins
      Aging Type                : Absolute
      SecureStatic Address Aging : Disabled
      Maximum MAC Addresses      : 10
      Total MAC Addresses        : 1
      Configured MAC Addresses  : 0
      Sticky MAC Addresses      : 0
      Last Source Address:Vlan  : 1110.353f.c091:2
      Security Violation Count  : 0

      Dynamically learned MAC addresses on the port that are stored in the running configuration.[/li]
    8)
  • 1 Comment sorted by
  • 640-878 SPNGN2 Exam Topics

    Exam Description

    The 640-878 Building Cisco Service Provider Next-Generation Networks, Part 2 exam is associated with the Cisco CCNA Service Provider certification. This exam tests the knowledge and skills that are necessary to implement and support a service provider network. Candidates can prepare for this exam by taking the Building Cisco Service Provider Next-Generation Networks, Part 2 (SPNGN2) course.

    Exam Topics
    The following topics are general guidelines for the content that is likely to be included on the Building Cisco Service Provider Next-Generation Networks, Part 2 exam. However, other related topics may also appear on any specific delivery of the exam. To better reflect the contents of the exam and for clarity purposes, the guidelines that follow may change at any time without notice.

    IP NGN Architecture
    • [li]Identify the functional components that are required to meet a given network specification[/li]
      [li]Troubleshoot common network problems at Layers 1, 2, 3, 4, and 7 using a layered-model approach[/li]
      [li]Describe the different types of service providers[/li]
      [li]Describe service provider principal and reference next-generation network (NGN) architecture[/li]
      [li]Describe the IP address and autonomous system (AS) number allocation process via the Internet Assigned Numbers Authority (IANA) and Regional Internet Registries (RIRs)[/li]

    Switched Network Technologies II
    • [li]Configure enhanced switching technologies (including Rapid Spanning Tree Protocol [RSTP], Multiple Spanning Tree [MST], and Per VLAN Spanning Tree [PVST]) on Cisco IOS Software switches[/li]
      [li]Describe how VLANs create logically separate networks and the need for routing between them[/li]
      [li]Configure VLANs on Cisco IOS Software switches[/li]
      [li]Configure trunking on Cisco IOS Software switches[/li]
      [li]Configure inter-VLAN routing[/li]
      [li]Configure Resilient Ethernet Protocol (REP) on Cisco IOS Software switches[/li]
      [li]Configure queue-in-queue (QinQ) on Cisco IOS Software switches[/li]

    Routed Network Technologies II
    • [li]Configure basic single-area Open Shortest Path First version 2 (OSPFv2) and OSPF version 3 (OSPFv3) routing on Cisco routers[/li]
      [li]Configure basic single-area Intermediate System-to-Intermediate System (IS-IS) routing on Cisco routers[/li]
      [li]Describe the differences between static versus dynamic routing as well as distance vector versus link-state routing protocol operations[/li]
      [li]Configure basic Border Gateway Protocol (BGP) routing on Cisco routers[/li]
      [li]Describe the address family concept on Cisco routers[/li]
      [li]Describe IPv6 transitioning technologies[/li]
      [li]Configure First Hop Redundancy Protocol (FHRP) (including Hot Standby Router Protocol [HSRP], Virtual Router Redundancy Protocol [VRRP], and Gateway Load Balancing Protocol [GLBP]) on Cisco routers[/li]
      [li]Implement access control list (ACL) on Cisco routers[/li]
      [li]Describe carrier-grade NAT (CGN) and Network Address Translation 64 (NAT64)[/li]
      [li]Describe Multiprotocol Label Switching (MPLS) functions in the service provider IP NGN[/li]
      [li]Configure Label Distribution Protocol (LDP) on Cisco routers[/li]

    Cisco Operating Systems and Platforms II
    • [li]Manage the Cisco IOS XR configurations and software packages[/li]
      [li]Describe Cisco IOS XE software packages[/li]
      [li]Describe Cisco service provider router platforms, their operating system, and their placement in the service provider IP NGN[/li]

    Network Set authentication, frame-relay, NAT, DHCP
    IOS XR
    Border Gateway Protocol (BGP)
    Internet Protocol version 6 (IPv6)
    VLAN
    Cisco Resilient Ethernet Protocol (REP)

    Network service provider
    http://en.wikipedia.org/wiki/Network_service_provider


    Cisco ASR 1000 Series: ISSU Deployment Guide and Case Study
    http://www.cisco.com/en/US/prod/collateral/routers/ps9343/white_paper_c11_517184.html


    Cisco ASR 1000 Series Aggregation Services Routers Ordering Guide
    http://www.cisco.com/en/US/prod/collateral/routers/ps9343/product_bulletin_c07-448862.html


    The bit error rate or bit error ratio (BER) is the number of bit errors divided by the total number ...
    http://en.wikipedia.org/wiki/Bit_error_rate


    What is Cisco IOS XE?
    http://www.cisco.com/en/US/prod/collateral/iosswrel/ps9442/ps11192/ps11194/QA_C67-622903.html

    • [li]MST:
      Spanning-tree mode can be used to map several VLAN to a single spanning-tree instance.
      Spanning-tree mode uses the name command to configure a region name.

      [/li]
      [li]Turboboot is procedure used as the last resort disaster recovery procedure to completely replace the currently installed IOS XR software on Cisco IOS XR routers.

      [/li]
      [li].vm is file extension indicates a bootable installation file in Cisco IOS XR software.

      [/li]
      [li]When configuring an ACL entry, 10.8.144.0 0.0.7.255 is network and wildcard mask matches IP addresses 10.8.144.0 to 10.8.151.255.

      [/li]
      [li]192.168.80.64 to 192.168.80.79 are IP addresses matched by the permit 192.168.80.64 0.0.0.15 access-list entry.

      [/li]
      [li]NAT444:
      NAT is performed by the CPE and also by the service provider router.
      NAT packets traverse three IPv4 addressing domains.

      [/li]
      [li]Refer to the output:
      ipv4 access-list FILTER
      10 permit tcp any 192.168.15.32 0.0.0.15 eq www
      20 deny ipv4 any 192.168.15.32 0.0.0.15
      30 permit ipv4 any any

      The access list has been configured on the Gi0/0/0/0 interface in the inbound direction. Example Packets that are sourced from 10.1.1.1 TCP port 1060, if they are routed to the Gi0/0/0/0 interface, will be permitted:
      Destination IP address: 192.168.15.49, destination TCP port: 80
      Destination IP address: 192.168.15.49, destination TCP port: 8080
      Destination IP address: 192.168.15.46, destination TCP port: 80
      Destination IP address: 192.168.15.36, destination TCP port: 80

      [/li]
      [li]NAT64:
      There are two types of NAT64 (stateful or stateless).
      The DNS64 server embeds the IPv4 address from the DNS A record with a preconfigured IPv6 translation prefix.

      [/li]
      [li]Refer to the output:
      ipv4 access-list FILTER
      10 deny tcp any 10.10.192.0 0.0.3.255 eq telnet
      20 permit ipv4 any 10.10.192.0 0.0.3.255
      30 deny ipv4 any any

      The access list has been configured on the Gi0/0/0/0 interface in the inbound direction. Example packets that are sourced from 172.16.1.1 TCP port 1050, if they are routed to the Gi0/0/0/0 interface, will be permitted:
      Destination IP address: 10.10.192.201, destination TCP port: 80
      Destination IP address: 10.10.193.255, destination TCP port: 80

      [/li]
      [li]GLBP is first-hop router redundancy protocol uses the active virtual gateway to assign a virtual MAC address to the active virtual forwarders.

      [/li]
      [li]BGP weight attribute on Cisco routers:
      It is only locally significant.
      Routes with higher weight are the preferred routes.

      [/li]
      [li]AS path is BGP attribute is also used for loop prevention.
      As RFC 4271 says, "AS loop detection is done by scanning the full AS path (as specified in the AS_PATH attribute), and checking that the autonomous system number of the local system does not appear in the AS path".

      [/li]
      [li]The permit 172.16.32.0 0.0.15.255 access-list entry permits exactly 172.16.32.0 to 172.16.47.255 IP address range.

      [/li]
      [li]On the Cisco ME 3400 switch, spanning tree is enabled by default on NNI type of switch port.

      [/li]
      [li]Refer to the two show output examples below. The switch with the e8ba.70b5.7180 MAC address is the root bridge for VLAN 80.

      image

      [/li]
      [li]Refer to the Cisco IOS XR commands exhibit.
      RP/0/RSP0/CPU0:PE7#install activate disk0:asr9k-video-p-4.1.0
                                          ^
      % Invalid input detected at '^' marker

      RP/0/RSP0/CPU0:PE7#show user all
      Tue Sep 20 21:39:00.331 UTC
      Username: admin
      Groups: root-system
      <output omitted>

      The router administrator is trying to activate a software package on the router but is not able to do so. The router needs to be in the admin EXEC mode.

      [/li]
      [li]During the BGP route selection process on Cisco routers, weight is BGP attribute examined first, to determine the best path to use.

      [/li]
      [li]NSP is type of service provider responsible for offering backbone connectivity services to other service providers.

      [/li]
      [li]Cisco IP NGN service providers can offer multiple services to their customers by using IP/MPLS is type of technology in their core networks.

      [/li]
      [li]ISPs use BGP is protocol to establish peering sessions in an Internet exchange point environment.

      [/li]
      [li]You are enabling OSPF on a router and notice that all the Fast Ethernet and the Gigabit Ethernet interfaces have the same OSPF cost of 1. Change the OSPF auto-cost reference bandwidth is single configuration can make in router ospf configuration mode so that the Fast Ethernet interfaces have a higher OSPF cost than the Gigabit Ethernet interfaces.

      [/li]
      [li]On Cisco IOS XR software.
      router ospf 1
      area 0
        interface gi0/0/0/0

      Is set of commands enables OSPF area 0 on the Gi0/0/0/0 interface that has an IPv4 IP address.

      [/li]
      [li]Statements about OSPFv2 or OSPFv3 authentication:
      OSPFv3 uses IPsec for authentication and encryption.
      On Cisco IOS XR platforms, OSPFv3 authentication can be configured at the OSPF routing process, area, or interface level.
      OSPF authentication on Cisco IOS and IOS XE platforms can be configured per area or per interface.

      [/li]
      [li]In IS-IS routing, the NSEL must always be 00 to identify the router.

      [/li]
      [li]You have just enabled IS-IS on the lab testing network. You notice that IS-IS is not using the optimal path selection based on the interface bandwidth. Currently, the IS-IS routing process seems to be selecting the best path based on the hop count.
      Change the default IS-IS metric on each of the router interfaces to better correspond to the interface bandwidth is configuration change can make to cause IS-IS to select the optimal path based on the interface bandwidth.

      [/li]
      [li]You have installed a new router and configured OSPF on it. However, this new router is not able to establish an OSPF neighbor relationship with the neighbor OSPF router. Conditions could cause this problem:
      Mismatched OSPF area ID between the new router and the neighbor router.
      Mismatched OSPF hello/dead interval between the new router and the neighbor router.
      Mismatched OSPF authentication data between the new router and the neighbor router.
      Mismatched interface MTU between the new router and the neighbor router.

      [/li]
      [li]Refer to the Cisco IOS XR configuration:
      router isis 1
      net 49.0001.0100.0200.1001.00
      address-family ipv4 unicast
        metric-style wide
      address-family ipv6 unicast
        metric-style wide

      This router belongs to area ID 0001.

      [/li]
      [li]MPLS PHP is implemented to increase the performance on the egress edge LSR. PHP allows the egress edge LSR to perform only one lookup to route the IP packet based on destination IP address and routing table.

      [/li]
      [li]Refer to the exhibit.

      image

      MPLS LDP operations:
      The incoming label for 10.2.10.1/32 is 16010 (which is allocated by the local router), and the outgoing label is 22 (as advertised by the next-hop router).
      The ImpNull outgoing label for the 192.168.102.0/24 network means that the outgoing label should be removed when sending packets to the 192.168.112.40 next-hop router, when the incoming label is 16003.
      The outgoing label of 22 for 10.2.10.1/32 is learned from the 192.168.112.40 LDP neighbor.

      [/li]
      [li]On Cisco IOS XR software, LDP is enabled on each interface, using the interface command under mpls ldp (MPLS LDP configuration mode).

      [/li]
      [li]REP configurations on a Cisco ME 3400 switch port:
      The port where the segment terminates is called the edge port.
      With REP, at least one port is always blocked in any given segment-that is, the alternate port.
      Use the rep segment number command to enable REP on the switch port.
      The port must be an NNI type and must be in trunk mode.

      [/li]
      [li]A VLAN is a logical grouping of switch ports that belong to these:
      The same IP subnet
      The same broadcast domain

      [/li]
      [li]Refer to the configuration:
      SwitchX#configure terminal
      SwitchX(config)#interface fa0/11
      SwitchX(config-if)#switchport mode trunk
      SwitchX(config-if)#end

      VLAN 1 traffic is sent untagged on the fa0/11 trunk port.

      [/li]
      [li]Refer to the partial configurations:
      !ME3400
      !
      ip routing
      !
      vlan 10
      vlan 20
      interface Fa0/1
      switchport access vlan 10
      interface Fa0/2
      switchport access vlan 20
      !

      interface vlan 10
        ip address 192.168.10.1 255.255.255.0
      !
      interface vlan 20
        ip address 192.168.20.1 255.255.255.0
      !

      Is additional configurations are required to enable inter-VLAN routing for VLANs 10 and 20 on the Cisco ME 3400 switch using the metro IP access image.

      [/li]
      [li]Refer to the topology diagram in the exhibit.

      image

      Interface configuration commands on the Cisco ME 3400-1 switch Fa 0/1 interface are required to support the VLANs for Customer A to be trunked across the service provider network:
      switchport mode dot1q-tunnel
      switchport access vlan 30

      [/li]
      [li]2002::/16 is IPv6 address block is reserved for 6to4 tunneling.

      [/li]
      [li]When upgrading a Cisco ASR 1001 Router, to run the router using individual subpackages is the request platform software package expand file bootflash:image-name command required.

      [/li]
      [li]Cisco 12000 GSR is Cisco router platform supports running either the Cisco IOS or IOS XR operating system.
      The CRS-1 platform natively runs the IOS XR operating system. The c12000 platform, originally being an IOS router, can be upgrade to run IOS XR. However, c12000 hardware, including line cards (LC) as well as route processors (RP), must be checked for XR compliance.
      TURBOBOOT refers to a fresh boot of the router from ROMMON. TURBOBOOT is required if an IOS router is being converted to IOS XR or as a last resort disaster recovery in the case of CRS-1. If the router is already running an IOS XR image, there is no need to TURBOBOOT the router for an upgrade or downgrade.
      A new c12000 platform can be ordered prebaked as an IOS XR router; however, there will always be cases where an IOS running c12000 needs to install IOS XR.

      [/li]
      [li]You want to configure HSRP between a Cisco IOS and a Cisco IOS XR router for the 192.0.2.0/24 subnet. Half of the PCs on the 192.0.2.0/24 subnet are configured to use 192.0.2.1 as the default gateway, and the other half of the PCs are configured to use 192.0.2.254 as the default gateway. The intent is to load balance the traffic across both routers.
      IOS and IOS XR configurations are needed:
      ! IOS
      interface GigabitEthernet 0/0
      ip address 192.0.2.2 255.255.255.0
      standby 1 ip 192.0.2.1
      standby 1 priority 105
      standby 1 preempt
      standby 2 ip 192.0.2.254
      standby 2 priority 95
      standby 2 preempt
      ! IOS-XR
      interface GigabitEthernet 0/0/0/0
      ip address 192.0.2.3 255.255.255.0
      router hsrp
      interface GigabitEthernet 0/0/0/0
        hsrp 1 ipv4 192.0.2.1
        hsrp 1 priority 95
        hsrp 1 preempt
        hsrp 2 ipv4 192.0.2.254
        hsrp 2 priority 105
        hsrp 2 preempt

      [/li]
      [li]On Cisco IOS XR software, the address-family command options in IS-IS configuration mode are valid:
      address-family ipv6 unicast
      address-family ipv4 unicast

      [/li]
      [li]On Cisco routers, the address-family configuration command in BGP configuration mode is used to enable multiprotocol BGP feature.

      [/li]
      [li]Your switch network has been configured to support mulitple VLANs. In order for the users on one VLAN to communicate with users on another VLAN, Enable inter-VLAN routing on a router or on a Layer 3 capable switch is additional configuration is required.

      [/li]
      [li]Within an MPLS domain, LFIB is table used by the label switch routers to make forwarding decisions when a labeled packet is received.

      [/li]
      [li]On Cisco IOS XR software, psuedo-atomic is the default commit option.

      [/li]
      [li]Refer to the show command exhibit.

      image

      It shows the contents of the uncommitted configuration session (target configuration).

      [/li]
      [li]When configuring a new VLAN on Cisco IOS switches, VLAN ID is configuration parameter that required.

      [/li]
      [li]Must have redundant RPs is a requirement for performing Cisco IOS ISSU on the Cisco IOS XE-based ASR 1006 and ASR 1013 routers.

      [/li]
      [li]Refer to the partial Cisco IOS router configuration exhibit.
      interface FastEthernet0/0
      no ip address
      no shut
      !
      interface FastEthernet0/0.1
      ip address 192.168.1.1 255.255.255.0
      !
      interface FastEthernet0/0.2
      ip address 192.168.2.1 255.255.255.0
      !
      interface FastEthernet0/0.3
      ip address 192.168.3.1 255.255.255.0
      !

      To provide inter-VLAN routing, the Fa0/0.1, Fa0/0.2 and Fa0/0.3 subinterface configuration is missing the encapsulation dot1Q vlan-id subinterface configuration command.

      [/li]
      [li]Refer to the partial Cisco IOS XR BGP configuration exhibit.
      router bgp 64500
      address-family ipv4 unicast
        network 10.1.1.1/32
      !
      address-family ipv6 unicast
        network 2001:db8:10:1:1::1/128
      !
      neighbor 10.2.1.1
        remote-as 64500
        update-source Loopback0
        address-family ipv4 unicast
        !
      !
      neighbor 192.168.101.11
        remote-as 64501
        password encrypted 13061E010803
        address-family ipv4 unicast
        route-policy Test1 in
        route-policy Test1 out
        !
      !
      neighbor 2001:db8:10:2:1::1
        remote-as 64500
        address-family ipv6 unicast
        !
      !
      neighbor 2001:db8:192:168:101::11
        remote-as 64501
        address-family ipv6 unicast
        route-policy Test1 in
        route-policy Test1 out
        !
      !
      !
      end

      This router uses its Loopback 0 interface IP address when establishing BGP peering with the 10.2.1.1 router.
      Test1 refers to a route policy that is defined using the RPL.

      [/li]
      [li]When enabling an EBGP peering configuration is a route-policy configuration needed on a Cisco IOS XR router using RPL.

      [/li]
      [li]Refer to the partial Cisco IOS router configuration exhibit.
      interface Tunnel0
      ipv6 address 2001:db8:3::2/64
      tunnel source GigabitEthernet0/0
      tunnel destination 209.165.201.1
      tunnel mode ipv6ip
      !

      Manual 6in4 tunnel is type of tunnel configuration is shown.

      [/li]
      [li]Protocols are most often deployed in Cisco IP NGN multiservices core networks to support services like VPNs:
      MPLS
      multiprotocol BGP

      [/li]
      [li]Resilient Ethernet Protocol is segment protocol provides fast and predictable convergence (typically within 50 ms) in Layer 2 Ethernet ring topologies.
      Resilient Ethernet Protocol (REP) on the Cisco ME 3400E Ethernet Access switch. REP is a Cisco proprietary protocol that provides an alternative to Spanning Tree Protocol (STP) to control network loops, handle link failures, and improve convergence time. REP controls a group of ports connected in a segment, ensures that the segment does not create any bridging loops, and responds to link failures within the segment. REP provides a basis for constructing more complex networks and supports VLAN load balancing.

      [/li]
      [li]Within an MPLS domain, FIB table is used by the ingress edge LSR to make forwarding decisions when an unlabeled IP packet is received.

      [/li]
      [li]Access control lists on a Cisco IOS router:
      Router-generated packets cannot be filtered by the interface ACLs on the router.
      There must be at least one permit statement in an ACL, or all traffic is denied.
      The more specific ACL entries should be placed at the top of the ACL.

      [/li]
      [li]access-list 101 permit tcp 10.1.128.0 0.0.1.255 eq 3030 192.168.1.0 0.0.0.15 eq www is Cisco IOS access list permits HTTP traffic that is sourced from network 10.1.128.0/23 port 3030 and that is destined to network 192.168.1.0/28

      [/li]
      [li]Active and standby IOS processes that are running on a single RP is dual IOS mode on the Cisco ASR 1001 Router.

      [/li]
      [li]Cisco ASR1K is Cisco platform runs the Cisco IOS XE operating system.

      [/li]
      [li]A service provider needs to implement a managed CE device that supports Cisco IOS ISSU, and the current CE support staff is highly trained in Cisco IOS only. Cisco ASR1K is Cisco router platform should the service provider implement as the managed CE device.

      [/li]
      [li]On Cisco IOS XR software, the valid address-family configuration command options in static route configuration mode:
      address-family ipv4 unicast
      address-family ipv4 multicast
      address-family ipv6 unicast
      address-family ipv6 multicast

      [/li]
      [li]Service provider network requirements:
      Service providers connect customers to the Internet.
      Multiple access technologies are supported.
      Customers can connect directly using copper, wireless, or fiber-optic links.

      [/li]
      [li]Common ISP access network technologies:
      Cable modem
      DSL
      PON

      [/li]
      [li]Cisco platforms are classified as core routers:
      Cisco XR 12000
      Cisco ASR 9010
      Cisco CRS-3

      [/li]
      [li]Cisco IOS XE is identical in look and feel to Cisco IOS software.

      [/li]
      [li]VLAN implementation in a Layer 2 switch environment:
      VLANs can span across multiple switches.
      802.1Q encapsulation is used to identify different VLANs on a trunk port.
      802.1AD supports VLAN overlap.

      [/li]
      [li]Refer to the configuration example exhibit.
      S1(config)# interface f0/1
      S1(config-if)# switchport access vlan 118
      S1(config-if)# switchport mode dot1q-tunnel
      S1(config-if)# interface f0/3
      S1(config-if)# switchport access vlan 209
      S1(config-if)# switchport mode dot1q-tunnel

      Is a QinQ VLAN of 118 and 209 are configured.

      [/li]
      [li]The link state routing process:
      Each router in the area floods LSPs to all neighbors.
      All routers in the area have link state databases.

      [/li]
      [li]Carrier-grade NAT:
      It conserves IPv4 addresses.
      A service provider issues private IP addresses to its customers.[/li]

    Interconnecting ISP Networks
    Types of Service Providers
    A service provider is an entity that provides different kinds of services to other entities. Five types exist:
    • [li]Communications service provider (CSP)[/li]
      [li]Telecommunications service provider (TSP)[/li]
      [li]Network service provider (NSP)[/li]
      [li]Internet service provider (ISP)[/li]
      [li]Application service provider (ASP)[/li]

    Internet Service Provider Basics
    • [li]ISP provides access to common network called Internet[/li]
      [li]ISP provides service to:
      [list][li]Home user subscribers
      [list][li]ADSL, cable internet, and FTTH[/li]
      [li]Internet access, VoIP, and IPTV[/li]
    [/li]
    [li]Business subscribers
    • [li]ADSL, SDSL, and leased lines[/li]
      [li]Internet access, private VPNs, and VoIP[/li]
    [/li][/list][/li][/list]
    Interconnecting Service Providers
    • [li]Three entities in service provider relationship model:
      [list][li]Customers
      [list][li]Pay ISP for providing Internet access to them[/li]
    [/li]
    [li]Peers
    • [li]Exchange traffic for free, which is a mutual benefit[/li]
    [/li]
    [li]Transit partners
    • [li]You pay your partner to access a certain range of networks[/li]
    [/li][/list][/li]
    [li]Relationships are defined in settlements between partners.[/li]
    [li]The Internet is based on the principle of global reachability.[/li]
    [li]Each network has to do one of two things:
    • [li]Pay another network for transit[/li]
      [li]Peer with every other network[/li]
    [/li][/list]
    Internet Exchange Point (IXP)
    • [li]The IXP is the physical infrastructure that service providers use to exchange traffic.[/li]
      [li]IXPs reduce traffic to upstream providers.
      [list][li]Per-bit delivery cost reduction[/li]
    [/li]
    [li]Routing efficiency and fault tolerance is improved.[/li]
    [li]BGP is used for traffic routing.[/li][/list]
    Types of Internet Service Providers
    • [li]Tier 3 ISP[/li]
      [li]Tier 2 ISP[/li]
      [li]Tier 1 ISP[/li]

    Tier 3 ISP
    • [li]Purchase transit links from Tier 1 or Tier 2 ISPs[/li]
      [li]Peer with regional partners for cutting costs[/li]
      [li]Provide Internet access to end  customers
      [list][li]Focused on specific region[/li]
      [li]Usually low price access[/li]
      [li]Usually lower access speeds[/li]
    [/li]
    [li]Customers are usually home user subscribers[/li][/list]
    Tier 2 ISP
    • [li]Purchase transit links from Tier 1 ISPs[/li]
      [li]Peer with other ISPs for cutting costs (using IXP)[/li]
      [li]Provide Internet access to:
      [list][li]End customers (home and business)
      [list][li]Focus on business customers[/li]
      [li]Charge higher prices[/li]
      [li]Offer higher speeds[/li]
    [/li]
    [li]Tier 3 ISPs[/li][/list][/li][/list]
    Tier 1 ISP
    • [li]Large national or international ISPs
      [list][li]Reach every other network on the Internet without purchasing IP transit links or paying settlements[/li]
    [/li]
    [li]Transit-free network
    • [li]Peers with (every) other Tier 1 ISP[/li]
      [li]Highest-speed connections[/li]
      [li]Very reliable networks[/li]
      [li]Usually expensive[/li]
    [/li]
    [li]Customers
    • [li]Lower-tiered ISPs[/li]
      [li]Large companies[/li]
    [/li][/list]
    Global IP Address Space Management
    Internet Number Distribution
    • [li]Internet Assigned Numbers Authority (IANA)
      [list][li]Responsible for allocation of globally unique:
      [list][li]IP addresses[/li]
      [li]AS number allocation[/li]
      [li]DNS root zone management[/li]
      [li]Protocol parameters[/li]
    [/li]
    [li]IANA is operated by Internet Corporation for Assigned Names and Numbers (ICANN)[/li][/list][/li][/list]
    Hierarchical Structure
    • [li]Five Regional Internet Registries (RIRs)
      [list][li]Manage and distribute Internet parameters within their respective regions[/li]
      [li]IANA delegates Internet resources to RIRs[/li]
    [/li]
    [li]Local Internet Registry (LIR)
    • [li]Assigns address space to its users (that is, end users or other ISPs)[/li]
      [li]RIR delegates Internet resources to LIR[/li]
      [li]LIR can be:
      [list][li]ISP[/li]
      [li]Enterprise[/li]
      [li]Academic institution[/li]
    [/li][/list][/li]
    [li]National Internet Registry (NIR)
    • [li]Works within a country or economic unit[/li]
    [/li]
    [li]End Users
    • [li]Customers that need Internet access
      [list][li]IP address[/li]
      [li]AS number[/li]
    [/li][/list][/li][/list]
    IP Address Space
    • [li]End user requests IP address by its ISP
      [list][li]IPv4 address or block of addresses[/li]
      [li]IPv6 block of addresses
      [list][li]/64 address space (network) for end users[/li]
      [li]/48, /52, and /56 address spaces (networks) for business users[/li]
    [/li][/list][/li]
    [li]ISP distributes addresses from its assigned address space[/li]
    [li]IP address space can be:
    • [li]Provider Independent (PI)
      [list][li]Assigned by RIR from its special address space[/li]
      [li]A way to make your network multihomed[/li]
      [li]End user keeps address space[/li]
      [li]Results in big routing tables[/li]
    [/li]
    [li]Provider Assigned (PA)
    • [li]Assigned by ISP from ISP address space[/li]
      [li]End user needs to renumber when changing ISP[/li]
    [/li][/list][/li][/list]
    Global Routing
    IP Addresses and Routing
    • [li]Routing is used to forward traffic from the source network to the destination network[/li]
      [li]Routers pass traffic between networks based on a routing table.
      [list][li]The routing table is built by a routing algorithm.
      [list][li]BGP (used for route distribution on the Internet)[/li]
      [li]OSPF (used internally in the service provider core network)[/li]
      [li]IS-IS (used internally in the service provider core network)[/li]
    [/li][/list][/li]
    [li]The RIR has only an indirect role in the routing process.
    • [li]The RIR helps to keep the routing table at manageable sizes.
      [list][li]Hierarchical structure of address space (IPv6)[/li]
      [li]Distribute larger blocks of address space[/li]
    [/li][/list][/li][/list]
    Autonomous System (AS)
    • [li]AS represents a group of routing prefixes (that is, list of IP addresses)
      [list][li]Group of devices under a single administrative control[/li]
      [li]Represented as a 2-Byte number[/li]
    [/li]
    [li]AS information is used in the routing process[/li]
    [li]Three types of autonomous systems
    • [li]Stub AS
      [list][li]Connected to only one AS (and ISP)[/li]
      [li]Only one connection to the Internet[/li]
    [/li]
    [li]Multihomed AS
    • [li]Connected to two or more autonomous systems[/li]
      [li]Redundant connection to the Internet[/li]
    [/li]
    [li]Transit AS
    • [li]Provide connection through itself to other networks[/li]
      [li]ISPs use transit autonomous systems[/li]
    [/li][/list][/li][/list]
    BGP Routing Protocol
    • [li]BGP Routing Protocol
      [list][li]Basic routing protocol on the Internet[/li]
      [li]Exchange prefix information between BGP peers
      [list][li]Between autonomous systems - EBGP[/li]
      [li]Inside one AS - IBGP[/li]
    [/li]
    [li]Is multiprotocol
    • [li]Carry information for multiple protocols (such as IPv4, IPv6, multicast, and VPN)[/li]
    [/li][/list][/li]
    [li]Size of routing table grows very fast
    • [li]Need more memory and CPU load for processing routing table[/li]
      [li]Route aggregation and route summarization is used[/li]
    [/li][/list]
    Multihoming
    • [li]Multihoming is used to increase the reliability of the Internet connection for an IP network.[/li]
      [li]Multihoming customer site can have:
      [list][li]Multiple connections to the same ISP[/li]
      [li]Multiple connections to multiple ISPs[/li]
    [/li][/list]
    IPv4 Multihoming: Two ISPs
    • [li]A network must have its own
      [list][li]IP address space[/li]
      [li]AS number[/li]
    [/li]
    [li]BGP is used for routing.[/li]
    [li]Redundant gateway routers are suggested.[/li]
    [li]Prefixes smaller than /24 usually are filtered by the ISP.[/li][/list]
    IPv6 Multihoming
    • [li]IPv6 is designed to have multiple unicast addresses per node:
      [list][li]Different scopes[/li]
      [li]Graceful renumbering[/li]
    [/li]
    [li]Many nodes are expected to have multiple interfaces:
    • [li]Physical interfaces[/li]
      [li]Pseudo interfaces to support transition mechanisms[/li]
    [/li]
    [li]Sites that attach to multiple providers are expected to obtain multiple prefixes.[/li]
    [li]Use provider-independent addressing in the same fashion as in IPv4.[/li][/list]
    IPv6 Multihoming Solutions
    • [li]Immediate approach
      [list][li]"Multiconnecting"
      [list][li]Same ISP with multiple different links[/li]
      [li]No ISP redundancy[/li]
    [/li][/list][/li]
    [li]Short-term approach
    • [li]PI addressing space based on AS
      [list][li]From 2001:678::/29 in /48 chunks[/li]
      [li]Rapid routing table growth![/li]
    [/li][/list][/li]
    [li]Long-term approaches
    • [li]Protocol-based solution
      [list][li]SHIM6: Site Multihoming by IPv6 Intermediation[/li]
      [li]LISP: Locator Identifier Separation Protocol[/li]
    [/li][/list][/li][/list]
    Cisco IP NGP Architecture
    Cisco IP NGN Architecture
    • [li]The Cisco IP NGN architecture is a next-generation service provider infrastructure for video, mobile, cloud, and managed services.[/li]
      [li]The Cisco IP NGN provides an all-IP network for services and applications, regardless of access type.[/li]

    Cisco IP NGN Application Layer
    • [li]Applications providing attractive services to users:
      [list][li]Video on demand and electronic program guides[/li]
      [li]TelePresence[/li]
      [li]Location-based services, maps, and so on[/li]
      [li]Interactive messaging and social networks integration[/li]
    [/li][/list]
    Cisco IP NGN Services Layer
    • [li]Middle layer provides services to applications that are not limited to networking.[/li]
      [li]Service-layer middleware provides services to applications and utilizes the IP infrastructure.[/li]
      [li]Higher-level protocols provide service delivery.[/li]
      [li]Data storage and replication services are available.[/li]
      [li]Billing services, tracking services, and so on are available.[/li]

    Cisco IP NGN Infrastructure Layer
    • [li]Customer-to-provider connectivity focuses on the IP infrastructure layer of the Cisco IP NGN.[/li]

    Components of a Cisco IP NGN Infrastructure Layer
    Core Network
    Provides transport functions
    Implemented using IP and MPLS
    Core nodes interconnected with high-speed links
    Design principles:
    • [li]Operational simplicity[/li]
      [li]Highest availability of network paths[/li]
      [li]Highest scalability[/li]

    Mechanisms Used in Core Network
    Simple IGP protocol for routing in core network
    MPLS + MP-BGP
    • [li]LDP[/li]
      [li]Multiprotocol transport
      [list][li]IPv4 and IPv6 forwarding[/li]
      [li]Private VPNs[/li]
    [/li]
    [li]MPLS traffic engineering[/li]
    [li]QoS[/li][/list]
    Edge Network Functions
    Set of network devices that do the following:
    • [li]Perform subscriber management and control[/li]
      [li]Implement the Layer 2 or Layer 3 service edge
      [list][li]Residential Internet access[/li]
      [li]Business VPN[/li]
      [li]Video application edge[/li]
      [li]IP telephony application edge[/li]
    [/li][/list]
    Mechanisms Used in the Edge Network
    • [li]Network access policies
      [list][li]QoS and ACL[/li]
    [/li]
    [li]Session control policies (such as service authorization and prepaid service management)[/li]
    [li]Network forwarding policies
    • [li]L2TP[/li]
      [li]MPLS VPN tunnels
      [list][li]SLA and flexible customer routing policies[/li]
    [/li][/list][/li]
    [li]Admission control[/li]
    [li]Multicast
    • [li]VoD and IPTV[/li]
    [/li][/list]
    Aggregation Network
    Aggregation network comprises the following:
    • [li]Aggregation nodes[/li]
      [li]Distribution nodes[/li]

    Two basic types of physical topologies:
    • [li]Ring topology[/li]
      [li]Hub-and-spoke topology[/li]

    Aggregation Network Functions
    • [li]Advanced Ethernet services functions
      [list][li]Classification of traffic[/li]
      [li]Security features (such as ACLs, broadcast storm control, IP source guard, and so on)[/li]
      [li]DiffServ QoS policies[/li]
      [li]Pop, push, and swap 802.1Q and QinQ tags[/li]
    [/li]
    [li]Carrier Ethernet aggregation and transport functions
    • [li]MPLS and IP, IGP and LDP, and MPLS TE[/li]
      [li]Layer 2 transport (that is, TDM, ATM, and AToM)[/li]
      [li]Layer 3 transport (that is, IP unicast, multicast, and MPLS VPN)[/li]
    [/li]
    [li]Demarcation point between the aggregation network and edge network[/li][/list]
    Access Layer
    Access network comprises the following:
    • [li]Fixed access network nodes
      [list][li]DSL nodes (for residential and business)
      [list][li]ADSL, ADSL2+, and VDSL[/li]
    [/li]
    [li]PON nodes (for residential and business)
    • [li]GPON and EFM-PON[/li]
    [/li]
    [li]Ethernet access nodes
    • [li]802.1Q bridging[/li]
    [/li][/list][/li]
    [li]Mobile access network nodes
    • [li]Cell site gateway (CSG)
      [list][li]Supports 2G, 3G, and 4G mobile RAN[/li]
      [li]Connected trough TDM, SDH, and SONET[/li]
    [/li]
    [li]Packet microwave transport[/li][/list][/li][/list]
    Access Network Functions
    • [li]Subscriber isolation[/li]
      [li]Subscriber line identification[/li]
      [li]IGMP snooping[/li]
      [li]Support for TV broadcast[/li]
      [li]802.1p classification[/li]
      [li]ACLs, MAC filters, and BPDU filters[/li]

    Cisco IP NGN of the Future
    Trends in P-Networks
    • [li]By 2015, global IP traffic will reach an annual run rate of 966 exabytes per year
      [list][li]966 exabytes is equal to 8 times more than all IP traffic that was generated in 2008 (totaling 121 exabytes)[/li]
    [/li]
    [li]What is a zettabyte?
    • [li]One sextillion bytes[/li]
      [li]Approximately 10 to the 21st power (1,000,000,000,000,000,000,000) bytes[/li]
    [/li][/list]
    Global IP Traffic Drivers
    • [li]More devices
      [list][li]Nearly 15 billion connections[/li]
    [/li]
    [li]More Internet users
    • [li]3 billion Internet users[/li]
    [/li]
    [li]Faster broadband speeds
    • [li]Fourfold speed increase[/li]
    [/li]
    [li]More rich media content
    • [li]1 million video minutes per second[/li]
    [/li][/list]
    One Architecture for All Services
    • [li]A unified IP NGN that delivers video, mobile, and cloud services[/li]

    Residential Services
    • [li]The strategy to maximize service revenue and minimize subscriber turnover is to offer a complete set of bundled triple-play services to residential subscribers:
      [list][li]Voice[/li]
      [li]High-speed Internet[/li]
      [li]Broadcast TV and video on demand (VoD)[/li]
    [/li]
    [li]Bundled services are offered at attractive price points to encourage subscribers to purchase all services from a single provider.[/li][/list]
    Business Services
    • [li]Business subscribers are an important segment of many service provider customer bases.[/li]
      [li]The main business services that must be provided by the network today are the following:
      [list][li]MPLS VPN[/li]
      [li]Carrier Ethernet connectivity[/li]
      [li]Managed services[/li]
    [/li]
    [li]Business services typically provide secure bandwidth with dedicated quality of service (QoS).[/li][/list]
    Video Services
    • [li]Video services consist of broadcast IPTV and VoD.[/li]
      [li]Video can contribute large revenue to a service provider.[/li]
      [li]Unlike Internet traffic, video traffic is intolerant of delays, packet loss, and network outages.[/li]

    Cisco Routers in the Core Network
    Cisco Carrier Routing System (CRS-1 and CRS-3)
    Cisco CRS-1
    • [li]First generation of a Next-Generation Network (NGN) high-speed core router[/li]
      [li]New hardware:
      [list][li]Fully distributed[/li]
      [li]All features supported at line speed[/li]
    [/li]
    [li]New operating system - Cisco IOS XR:
    • [li]Modular[/li]
      [li]Designed for high availability[/li]
      [li]Consistent CLI[/li]
    [/li][/list]
    Cisco CRS-3
    • [li]Upgraded version of CRS-1 with 3.5 times better performance[/li]

    CRS-1 Components
    • [li]Route processor (RP)
      [list][li]Provides processing power[/li]
      [li]Additional RPs can be installed if more processing power is needed[/li]
    [/li]
    [li]Physical layer interface module (PLIM)
    • [li]Provides Layer 2 interface capabilities[/li]
      [li]May be replaced with different PLIM to meet interface type requirements[/li]
    [/li]
    [li]Modular Service Card (MSC)
    • [li]Independent of the PLIM[/li]
      [li]Provides processing support for the PLIM[/li]
    [/li]
    [li]Switch Fabric Module (SFM)
    • [li]Shipped with the chassis[/li]
      [li]Different for each platform[/li]
    [/li][/list]
    16-Slot CRS (Reference only)
    • [li]Full-size, shelf-contained enclosure
      [list][li]Does not need separate mounting rack[/li]
    [/li]
    [li]16 PLIM and MSC pairs
    • [li]PLIMs are installed in the front side[/li]
      [li]MSCs are installed in the back side[/li]
    [/li]
    [li]8 SFM cards[/li]
    [li]Separate redundant fan and alarm controllers[/li]
    [li]Ability to set up a multishelf system[/li]
    [li]Maximum forwarding rate
    • [li]1.2 Tb/s for CRS-1[/li]
      [li]4.48 Tb/s for CRS-3[/li]
    [/li][/list]
    8-Slot CRS (Reference only)
    • [li]Half-size chassis[/li]
      [li]8 PLIM and MSC pairs
      [list][li]PLIMs are installed in the front side[/li]
      [li]MSCs are installed in the back side[/li]
    [/li]
    [li]4 half-size SFM cards[/li]
    [li]The RP manages alarm and fan control[/li]
    [li]Maximum forwarding rate
    • [li]Up to 640 Gb/s for CRS-1[/li]
      [li]Up to 2.24 Tb/s for CRS-3[/li]
    [/li][/list]
    4-Slot CRS (Reference only)
    • [li]Half-size chassis[/li]
      [li]4 PLIM and MSC pairs[/li]
      [li]PLIMs and MSCs are installed in the front side[/li]
      [li]4 half-size SFM cards (installed in the back side)[/li]
      [li]The RP manages alarm and fan control[/li]
      [li]Maximum forwarding rate
      [list][li]Up to 320 Gb/s for CRS-1[/li]
      [li]Up to 1.12 Tb/s for CRS-3[/li]
    [/li][/list]
    Multishelf CRS-1 (Reference only)
    • [li]From 2 to 72 line card chassis (LCC)[/li]
      [li]From 1 to 8 fabric card chassis (FCC)[/li]
      [li]Highly scalable
      [list][li]Up to 1,152 line cards[/li]
      [li]Maximum data rate of 92 Tb/s[/li]
    [/li]
    [li]In LCCs, S123 type SFMs are replaced with S13 type SFMs[/li]
    [li]FCCs comprise the following:
    • [li]Up to 24 S2 type SFMs in the front[/li]
      [li]Up to 24 OIM cards in the back for connectivity with S13 cards in the LCCs[/li]
    [/li]
    [li]Switch fabric optical cables have a distance limit of 328 feet (100 m)[/li][/list]
    Cisco 12000 Series Routers (GSR)
    • [li]Gigabit switch router[/li]
      [li]Cisco IOS and IOS XR[/li]
      [li]Up to 1.28 Tb/s switching capacity (wire speed)[/li]
      [li]Fully redundant hardware
      [list][li]Fabric card redundancy[/li]
      [li]RP redundancy[/li]
      [li]Power supply redundancy[/li]
    [/li]
    [li]Field-upgradable fabric cards[/li][/list]
    16-Slot GSR (Reference only)
    • [li]Full-size chassis[/li]
      [li]Models:
      [list][li]Cisco 12016 (80 Gb/s)[/li]
      [li]Cisco 12416 (320 Gb/s)[/li]
      [li]Cisco 12816 (1.28 Tb/s)[/li]
    [/li]
    [li]Up to 40 Gb/s per slot with full-duplex throughput[/li]
    [li]One or two route processors[/li]
    [li]3 switch fabric cards (SFCs)[/li][/list]
    10-Slot GSR (Reference only)
    • [li]Half-size chassis[/li]
      [li]Models:
      [list][li]Cisco 12010 (50 Gb/s)[/li]
      [li]Cisco 12410 (200 Gb/s)[/li]
      [li]Cisco 12810 (800 Gb/s)[/li]
    [/li]
    [li]Up to 40 Gb/s per slot with full-duplex throughput[/li]
    [li]One or two route processors[/li]
    [li]5 switch fabric cards (SFCs)[/li][/list]
    4- and 6-Slot GSR (Reference only)
    • [li]One-quarter, rack-size chassis - 6 slot[/li]
      [li]Models:
      [list][li]Cisco 12006 (30 Gb/s)[/li]
      [li]Cisco 12406 (120 Gb/s)[/li]
    [/li]
    [li]Up to 10 Gb/s per slot with full-duplex throughput[/li]
    [li]One or two route processors[/li]
    [li]3 switch fabric cards (SFCs)[/li][/list]
    • [li]1/8, rack-size chassis - 4 slot[/li]
      [li]Models:
      [list][li]Cisco 12404 (80 Gb/s)[/li]
    [/li]
    [li]Up to 10 Gb/s per slot with full-duplex throughput[/li]
    [li]One or two route processors[/li]
    [li]1 switch fabric card (SFC)[/li][/list]
    Cisco Routers and Switches in the Edge and Aggregation Network
    Cisco ASR 9000 Series
    • [li]Increased power and simplicity to the edge of the provider network[/li]
      [li]Fully distributed system
      [list][li]Packet forwarding decisions take place on individual line cards[/li]
      [li]Line cards equipped with highly specialized network processors[/li]
    [/li]
    [li]Redundant hardware
    • [li]Route Switch Processor[/li]
      [li]Switching fabric[/li]
      [li]Fans[/li]
      [li]Power supply[/li]
    [/li]
    [li]Modular operating system
    • [li]Cisco IOS XR is used[/li]
      [li]Microkernel with additional modules[/li]
      [li]Nonstop operation during image upgrade and module changes[/li]
    [/li][/list]
    Cisco ASR 9000 Components
    • [li]Route Switch Processor (RSP)
      [list][li]Performs control plane and management functions[/li]
      [li]Dual core CPU processor with 4-GB DRAM[/li]
      [li]Dual out-of-band 10/100/1000 management interface[/li]
    [/li]
    [li]Switch Fabric
    • [li]Fabric is logically separate from line card and RSP[/li]
      [li]Physically resides on RSP
      [list][li]Cisco ASR 9922 Router has separated SF and RP[/li]
    [/li]
    [li]Operates separately from RSP function[/li][/list][/li]
    [li]Line Card Support
    • [li]40/100/160-Gb/s line rate[/li]
      [li]Scalable architecture[/li]
      [li]Base and extended memory options[/li]
    [/li][/list]
    Cisco ASR 9922 Router (Reference only)
    • [li]43 RUs high[/li]
      [li]22 slot (20 line card slots)[/li]
      [li]RSPs segregated into RP and Fibre Channel
      [list][li]6+1 redundant Fibre Channels[/li]
      [li]2 RPs[/li]
    [/li]
    [li]Airflow: front to back[/li][/list]
    Cisco ASR 9010 Router (Reference only)
    • [li]21 RUs high[/li]
      [li]10 slot (8 line card slots)[/li]
      [li]Dual redundant RSPs
      [list][li]One switch fabric per RPs[/li]
    [/li]
    [li]Airflow: front to back[/li][/list]
    Cisco ASR 9006 Router (Reference only)
    • [li]10 RUs high[/li]
      [li]6 slot (4 line card slots)[/li]
      [li]Dual redundant RSPs
      [list][li]One switch fabric per RPs[/li]
    [/li]
    [li]Airflow: front to back[/li][/list]
    Cisco ASR 9000v Router (Reference only)
    • [li]1 RU high[/li]
      [li]44 SFP-based ports (1 Gb/s)[/li]
      [li]4 SFP+-based, 10-Gb/s ports[/li]
      [li]Functions as a remote line card
      [list][li]Maximum 80 km away from host ASR 9000 and ASR 9900[/li]
      [li]Cisco Network Virtualization (nV) Technology[/li]
    [/li][/list]
    Cisco 7600 Series Router
    • [li]Edge service provider and core enterprise router[/li]
      [li]High-performance service delivery[/li]
      [li]Up to 720-Gb/s crossbar switch fabric (using RSP720-10 Gigabit Ethernet)
      [list][li]40 Gb/s of switching fabric capacity per slot[/li]
    [/li]
    [li]Forwarding rate of up to 400 mpps[/li]
    [li]Redundancy
    • [li]Redundant supervisor[/li]
      [li]Redundant power supply[/li]
    [/li][/list]
    Cisco 7600 Series Chassis (Reference only)
    • [li]Cisco 7603 and 7603-S Routers
      [list][li]4 RUs[/li]
      [li]3 line card slots[/li]
      [li]96-mpps forwarding[/li]
      [li]240-Gb/s backplane capacity[/li]
    [/li][/list]
    • [li]Cisco 7604 Router
      [list][li]5 RUs[/li]
      [li]4 line card slots[/li]
      [li]144-mpps forwarding[/li]
      [li]320-Gb/s backplane capacity[/li]
    [/li][/list] 8)